Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 231818

Summary: Indic langauges are not working with Java applications
Product: [Fedora] Fedora Reporter: A S Alam <aalam>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: eng-i18n-bugs, fitzsim, francis.kung, mshao, tromey
Target Milestone: ---Keywords: i18n
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 4.1.2-8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-04 16:01:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
tar file with Screenshot + Application none

Description A S Alam 2007-03-12 10:40:34 UTC
Description of problem:
I have application call Mozilla translator, which is used for Mozilla translationm
when I run this application in any Indic locale envirnment
like:
(pa_IN.UTF-8), then it only show SQUARE boxes, but when run in
en_US/zh_CN/ja_JP/ko_KR, then it run in English interface, actually it is in
English Interface

Version-Release number of selected component (if applicable):
jpackage-utils-1.7.3-1jpp.2.fc7

How reproducible:
Everytime

Steps to Reproduce:
1.  pa_IN.UTF-8 gij -jar mt520.jar/ java -jar mt520.jar
2. check boxes on top
3. ko_KR.UTF-8 java -jar mt520.jar
  
Actual results:
SQUARE box on english interface

Expected results:
English should be available

Additional info:
attaching
1) Jar file for mt520.jar
2) Screenshot for pa_IN.UTF-8 and ko_KR.UTF-8

Comment 1 A S Alam 2007-03-12 10:40:34 UTC
Created attachment 149812 [details]
tar file with Screenshot + Application

Comment 2 A S Alam 2007-03-12 10:46:15 UTC
Sorry about component, changing it it gcc by following
java->gij->libgcj (rpm)->gcc (srpm)
can't confirm whether it is correct component

Thanks

Comment 3 A S Alam 2007-03-12 10:49:44 UTC
gcc-4.1.2-3

Comment 4 Jakub Jelinek 2007-03-12 13:28:53 UTC
Sorry, can't reproduce, it shows english menus in all cases.

Comment 5 Francis Kung 2007-03-19 15:56:19 UTC
From the screenshot, it looks like you are using KDE?  Can you confirm?

(I can't reproduce the error either, but I'm using GTK.  Different desktop
environments use different graphics peers.)

Comment 6 A S Alam 2007-03-20 03:58:24 UTC
Yes, using KDE Only

Comment 7 Francis Kung 2007-03-27 15:38:09 UTC
I can now reproduce this bug; the pa_IN.UTF-8 locale breaks once the
fonts-punjabi package is installed.  Working on a fix.

Comment 8 Francis Kung 2007-04-02 19:42:56 UTC
Patch to greatly expand our foreign-language support has gone into GNU Classpath.

Comment 9 Jakub Jelinek 2007-04-04 16:01:10 UTC
Patch backported to gcc-4.1.2-8, please check it out.