Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 231743

Summary: yum-updatesd has atrocious memory leak?
Product: [Fedora] Fedora Reporter: David Nielsen <gnomeuser>
Component: yumAssignee: Jeremy Katz <katzj>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: grunwald, larry.bartz, lmacken, peter
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: yum-3.1.7-2.fc7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-11 01:35:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150226    

Description David Nielsen 2007-03-11 01:17:31 UTC
Description of problem:
I noticed that yum-updatesd goes totally out of control and gobbles up a lot of
memory lately. E.g. it's currently registered as using 139MB of memory according
to gnome-system-monitor.

Version-Release number of selected component (if applicable):
yum-updatesd-3.1.4-1.fc7

How reproducible:
100%

Steps to Reproduce:
1. enable yum-updatesd

Comment 1 Jeremy Katz 2007-03-19 22:05:10 UTC
*** Bug 232411 has been marked as a duplicate of this bug. ***

Comment 2 Larry Bartz 2007-04-10 13:11:58 UTC
We observe similar behavior in yum-updatesd-3.0.5-1.fc6 on i386. The yum-
updatesd process grows by approx 6MB on every run_interval cycle. This behavior 
is consistent among several machines over a twenty-four hour period.

Comment 3 Larry Bartz 2007-04-18 14:01:59 UTC
Last week's update to yum-3.0.5-2.fc6 and yum-updatesd-3.0.5-2.fc6 did not 
alleviate the problem. Also, why did the update not remove yum-3.0.5-1.fc6 and 
yum-updatesd-3.0.5-1.fc6?





Comment 4 Joshua Jensen 2007-04-29 23:12:32 UTC
I've noticed the same thing.  yum-3.0.5-1.fc6 and yum-updatesd-3.0.5-1.fc6
didn't go away... I've got both the 3.0.5 and 3.0.6 packages.  Top's
sort-by-memory view is scary:

PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
2923 root      15   0  596m 327m 4748 S    0 32.8   0:15.47 yum-updatesd

I have a gig of memory... why is yum-updatesd taking 1/3rd of my system memory?
 I've seen it go up to 40 percent.  This needs to be addressed!

I've removed the 3.0.5 versions, and made sure the 3.0.6 packages verify... I'll
keep this bug posted as to if that helps solve the terrible memory consumption.

Comment 5 Larry Bartz 2007-05-03 18:41:16 UTC
Yesterday's updates to yum-3.0.6-1.fc6 and yum-updatesd-3.0.6-1.fc6 have not 
alleviated the memory leak. The yum-updatesd process still leaks approx 6MB on 
every run_interval cycle. Once again, the RPM package did not remove the 
previous version. 

Comment 6 David Nielsen 2007-05-11 01:35:43 UTC
All the comments seem to be against the FC6 version of yum but I opened the bug
against the F7 version. This seems to be behaving a whole lot better than it
used to. As this is blocking F7 more feedback on the current usage of
yum-3.1.7-2.fc7 or above would be nice so that this bug could potentially be closed.