Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 231246

Summary: fence_xvm programs do not correctly use incorporate key data for operations
Product: [Retired] Red Hat Cluster Suite Reporter: Lon Hohberger <lhh>
Component: fenceAssignee: Lon Hohberger <lhh>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 4CC: cluster-maint, rmccabe
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: RHBA-2007:0138 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-16 16:13:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
fix none

Description Lon Hohberger 2007-03-06 22:59:02 UTC
+++ This bug was initially created as a clone of Bug #231241 +++

Description of problem:

Fence_xvm and fence_xvmd do not correctly use the contents of
/etc/cluster/fence_xvm.key.

If multiple clusters are run on the same subnet without the multicast packets
being filtered, then it is possible for the following to occur:

* If another cluster has a virtual machine with the same name, it can
inadvertently fence the virtual machine.
* Due to a previous behavioral change, fence_xvmd now returns success if it has
never heard of the domain.

Both lead to false-success scenarios where a virtual machine has not been
correctly fenced.

It may be advantageous to give the virtual machine cluster the name or ID of its
parent (host) cluster in order to prevent these behaviors from occurring when no
authentication is used.

-- Additional comment from lhh@redhat.com on 2007-03-06 17:47 EST --
Created an attachment (id=149400)
Fixes behavior

Comment 1 Lon Hohberger 2007-03-06 22:59:02 UTC
Created attachment 149404 [details]
fix