Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 231170

Summary: gnome-terminal dies at startup with 'BadMatch (invalid parameter attributes)'
Product: [Fedora] Fedora Reporter: Tom London <selinux>
Component: cairoAssignee: Carl Worth <cworth>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: d.bz-redhat, dm, gauret, jukka.ketelaars, maxx, mcepl, mcepl, redhat, sangu.fedora, tjb
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-20 19:46:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tom London 2007-03-06 16:57:06 UTC
Description of problem:
Latest xorg-x11-server/drv-810 packages: gnome-terminal fails at start up with

The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1135 error_code 8 request_code 72 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.2.99.901-1.fc7.i386

How reproducible:
every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Adam Jackson 2007-03-06 19:04:04 UTC
Do you get the same error when attempting to run 'gnome-terminal --sync' ?

Comment 2 Tom London 2007-03-07 13:58:50 UTC
Yes, I get the same error.  No difference in behavior.

Comment 3 Adam Jackson 2007-03-07 17:18:39 UTC
Hmm.  Request code 72 is XPutImage, which has delightfully vague conditions
under which it can return BadMatch.  Lovely.

The only obvious thing I can think of is trying to start g-t with
XLIB_SKIP_ARGB_VISUALS=1.  That and backrevving g-t or vte.  But I can't see any
obvious changes to the X server between 1.2.0-1 and now that would introduce new
BadMatch conditions for PutImage.

Comment 4 Tom London 2007-03-07 18:00:30 UTC
Cool.  Works with XLIB_SKIP_ARGB_VISUALS=1 with only warnings about fonts:

(gnome-terminal:3946): Vte-WARNING **: Can not find appropiate font for
character U+4e00.


(gnome-terminal:3946): Vte-WARNING **: Can not find appropiate font for
character U+4e8c.


(gnome-terminal:3946): Vte-WARNING **: Can not find appropiate font for
character U+4e09.


(gnome-terminal:3946): Vte-WARNING **: Can not find appropiate font for
character U+56db.


(gnome-terminal:3946): Vte-WARNING **: Can not find appropiate font for
character U+4e94.


(gnome-terminal:3946): Vte-WARNING **: Can not find appropiate font for
character U+ac00.


(gnome-terminal:3946): Vte-WARNING **: Can not find appropiate font for
character U+ac01.


(gnome-terminal:3946): Vte-WARNING **: Can not find appropiate font for
character U+ac04.


(gnome-terminal:3946): Vte-WARNING **: Can not find appropiate font for
character U+ac08.


(gnome-terminal:3946): Vte-WARNING **: Can not find appropiate font for
character U+ac10.

A (perhaps spurrious) point: changing the version of server/drv packages and
restarting the desktop doesn't appear to 'work'.  That is, logging off/logging
on has different behavior from rebooting.

Something else I can try to help this?


Comment 5 Tom London 2007-03-07 18:03:48 UTC
Tried reverting to an earlier vte, get this afterwards:

gnome-terminal: error while loading shared libraries: libvte.so.9: cannot open
shared object file: No such file or directory

missing dependency or something?

Comment 6 Thomas J. Baker 2007-03-07 21:25:03 UTC
I just installed rawhide on my laptop this morning with intel video and get the
same error. Disabling desktop-effects makes gnome-terminal work. So it seem like
a server problem.

Comment 7 Tom London 2007-03-08 00:15:26 UTC
Uhhhh this problem seems to have gone away for me with today's Rawhide update.

Not obvious to me what 'fixed' this......

Comment 8 Tom London 2007-03-08 00:39:53 UTC
Sorry, premature.  Still failing with the same message.....

Comment 9 Aurelien Bompard 2007-03-09 12:09:11 UTC
This only happens when Compiz or Beryl is the window manager. If I start
gnome-terminal with metacity, and activate Compiz/Beryl afterwards,
gnome-terminal works fine.

Comment 10 sangu 2007-03-20 03:36:55 UTC
Please See : https://bugs.freedesktop.org/show_bug.cgi?id=10250

Maybe cairo bug?

Comment 11 Carl Worth 2007-03-20 19:46:59 UTC
(In reply to comment #10)
> Please See : https://bugs.freedesktop.org/show_bug.cgi?id=10250

Yes, that looks like it's exactly the bug. And it's fixed in cairo 1.4.2 which I
just sent off to be built in Fedora.

-Carl


Comment 12 Matěj Cepl 2007-03-20 20:44:33 UTC
*** Bug 231145 has been marked as a duplicate of this bug. ***

Comment 13 Didier 2009-11-25 13:35:17 UTC
I am experiencing this exact same bug again with FC12 (proprietary nVidia, compiz) when starting gnome-terminal from remote sessions.

- Package versions :
cairo-1.8.8-3.fc12.x86_64
gnome-terminal-2.28.1-1.fc12.x86_64
vte-0.22.2-1.fc12.x86_64
compiz-0.8.2-19.fc12.x86_64
xorg-x11-drv-nvidia-190.42-2.fc12.x86_64


- Relevant xorg.conf entries :
Option	    "AIGLX" "on"
Driver      "nvidia"
Option	    "AddARGBGLXVisuals" "True"
Option	    "Composite" "Enable"


The problem is circumvented by prepending "XLIB_SKIP_ARGB_VISUALS=1" to the command line, e.g. :
[user@remote ]$ XLIB_SKIP_ARGB_VISUALS=1 gnome-terminal

See also : https://bugzilla.gnome.org/show_bug.cgi?id=354767