Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 231158

Summary: Error Code 31
Product: Red Hat Satellite 5 Reporter: HTC Systems Admin <systems.admin>
Component: RegistrationAssignee: Bret McMillan <bretm>
Status: CLOSED DUPLICATE QA Contact: Corey Welton <cwelton>
Severity: high Docs Contact:
Priority: medium    
Version: unspecifiedCC: rhn-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-06 16:26:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description HTC Systems Admin 2007-03-06 16:09:14 UTC
Description of problem:

When running up2date register, I'm able to complete and submit the information 
for the system, but upon Exit, I receive this error:

[root@localhost ~]# up2date --register
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1245, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 749, in main
    if cfg['useRhn'] and not up2dateAuth.getLoginInfo():
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 161, in getLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 114, in login
    raise f
xmlrpclib.Fault: <Fault -31: '\nError Message:\n    Service not enabled for 
system profile: "HTC-CMS"\nError Class Code: 31\nError Class Info: \n     This 
system does not have a valid entitlement for Red Hat Network.\n     Please 
visit https://rhn.redhat.com/network/systems/entitlements.pxt\n     or login at 
https://rhn.redhat.com, and from the "Systems" tab,\n     select "System 
Entitlements" to enable RHN service for this system.\nExplanation: \n     An 
error has occurred while processing your request. If this problem\n     
persists please enter a bug report at bugzilla.redhat.com.\n     If you choose 
to submit the bug report, please be sure to include\n     details of what you 
were trying to do when this error occurred and\n     details on how to 
reproduce this problem.\n'>

Version-Release number of selected component (if applicable):


How reproducible:
Run up2date --register

Steps to Reproduce:
1.up2date --register
2.
3.
  
Actual results:
Same

Expected results:
Should work

Additional info:

Comment 1 Bret McMillan 2007-03-06 16:26:40 UTC

*** This bug has been marked as a duplicate of 231159 ***