Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2311

Summary: dhcpcd client not able to obtain lease in HSRP environment
Product: [Retired] Red Hat Linux Reporter: stevecs
Component: pumpAssignee: Erik Troan <ewt>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 6.0CC: aleksey
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-31 22:21:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description stevecs 1999-04-21 15:59:16 UTC
We have an ISC DHCP server (v2.0b1pl26) running under
Solaris v2.6.  This server is behind two cisco routers
using HSRP with a virtual gateway interface of 1.0.0.250.

The client machine is located behind two other routers
running HSRP w/ a virtual interface of 192.168.208.254.

DHCPDiscover is sent, received twice (due to HSRP all
broadcast packets are duplicated out each phsyical
interface, this is normal).  The server pings the IP
address it's about to assign, then the server sends
DHCPOffer to client which is also duplicated for each HSRP
physical interface.

The dhcpcd client indicates that no DHCP reply is recieved
when it actually IS sent to the mac address from the
router.  All other clients work (HP printers, Sun
workstations, Win95/NT boxes).  Only the linux system has
a problem.

This problem goes away if the linux system is on the same
subnet as the DHCP server.

Comment 1 David Lawrence 1999-06-11 19:44:59 UTC
Does this problem still occur with the latest errata release of pump
available at ftp://updates.redhat.com/6.0/i386?

Comment 2 Bill Nottingham 1999-08-31 22:21:59 UTC
closed, lack of input.