Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 230923

Summary: No Groups Available in any repository
Product: [Fedora] Fedora Reporter: das_deniz
Component: pirutAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-05 20:14:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
GroupsError: No Groups Available in any repository
none
different trace same endpoint none

Description das_deniz 2007-03-04 19:37:16 UTC
Description of problem:

after using pup for an update and then piruit to install the virtualization
group - piruit exited with an unhandled exception

Version-Release number of selected component (if applicable):

pirut-1.3.3-1.fc7
rpm-4.4.2-40.fc7
gnome-python2-gconf-2.17.92-2.fc7
python-libs-2.5-11.fc7
python-2.5-11.fc7
python-numeric-24.2-3
pygtk2-libglade-2.10.4-1.fc7
pygtk2-2.10.4-1.fc7

How reproducible:

seems rare - did not fail with next launch or post install of "authoring and
publishing" group ;)

Steps to Reproduce:
1. unknown - get pirut to install something and when it refreshes it may exhibit
this again.
2.
3.
  
Actual results:

exception (attached)

Expected results:

need more feedback in a status bar or something about what pirut and pup are
doing - there are too many long unresponsive delays with these tools for a
positive user experience.

Additional info:

Comment 1 das_deniz 2007-03-04 19:37:16 UTC
Created attachment 149217 [details]
GroupsError: No Groups Available in any repository

Comment 2 das_deniz 2007-03-04 19:48:41 UTC
Created attachment 149218 [details]
different trace same endpoint

was able to get it to happen again after some more package installs

Comment 3 Jeremy Katz 2007-03-05 20:14:41 UTC

*** This bug has been marked as a duplicate of 230877 ***