Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 230835

Summary: asus_acpi always loads
Product: [Fedora] Fedora Reporter: Ronny Fischer <ronny.fischer>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: lex.lists, maurizio.antillon, rvokal, triage
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-02-25 10:28:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ronny Fischer 2007-03-03 12:00:07 UTC
Description of problem:
the module asus_acpi is always loaded even I don't have a computer build by
Asus. Machine is a IBM Thinkpad R52.

Version-Release number of selected component (if applicable):
Fedora 7 Test 2, Kernel 2.6.20-1.2949

How reproducible:
always

Steps to Reproduce:
1. install Fedora on a non-Asus-machine
2.
3.
  
Actual results:
asus_acpi is (unecessary?) loaded

Expected results:
asus_acpi should not be needed by non Asus-machines

Additional info:
I have this bug since Fedora Core 6 and on two different computers (IBM Thinkpad
 and a custom build Desktop PC). Both machines doesn't contain ANY parts made or
build by Asus. So why this module is loading? It is quite annoying and I hope
there is a good reason for this.

Comment 1 Matthew Miller 2007-04-10 15:56:00 UTC
Bulk message: Fedora 7 test bugs should be filed against "devel", not against
test1/2/3. This isn't obvious, I know. Moving this report so it isn't lost.

Comment 2 Phil Knirsch 2007-05-16 14:29:38 UTC
Thats actually more of a kernel question/bug, so reassigning it to proper component.

Read ya, Phil

Comment 3 Chuck Ebbert 2007-05-16 19:10:57 UTC
asus_acpi is always loaded because of this piece of /etc/rc.d/rc.sysinit:

# Initialize ACPI bits
if [ -d /proc/acpi ]; then
    for module in /lib/modules/$unamer/kernel/drivers/acpi/* ; do
        module=${module##*/}
        module=${module%.ko}
        modprobe $module >/dev/null 2>&1
    done
fi

rc.sysinit is from the package "filesystem", owned by pknirsch


Comment 4 Ronny Fischer 2007-05-16 19:43:49 UTC
Is there a way to exclude a single kernel module like asus_acpi? Blacklisting 
the module via modprobe.conf does not work.

Comment 5 Phil Knirsch 2007-05-24 14:50:13 UTC
Actually, rc.sysinit is owned by initscripts, moving there.

Read ya, Phil

Comment 6 Bill Nottingham 2007-05-24 18:27:12 UTC
This will be removed when the modules support proper dmi-based aliases - this is
going upstream soon.

Comment 7 Bug Zapper 2008-04-03 23:36:49 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 8 Ronny Fischer 2008-04-12 12:14:44 UTC
Having freshly installed Fedora 8 on a secondary computer it seems that this 
bug is fixed now. No module asus_acpi is shown via lsmod.

That's like it should be.

Comment 9 John Poelstra 2008-04-16 00:51:41 UTC
Thanks for your update

Okay to close this bug?

Comment 10 Ronny Fischer 2008-04-16 06:18:41 UTC
Sure, you can close this one. Didn't know if I can do this on my own.

Thx

Ronny

Comment 11 Bug Zapper 2008-05-14 02:39:37 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping