Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 230781

Summary: Brasero instalation brokes mime types in a system
Product: [Fedora] Fedora Reporter: Marcin Zajaczkowski <mszpak>
Component: braseroAssignee: Denis Leroy <denis>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-30 12:33:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 213321    

Description Marcin Zajaczkowski 2007-03-02 20:48:36 UTC
Description of problem:
After installation of brasero package (0.5.2-1) my Fedora lost support for mime
types. In Nautilus all files are treated as a generic binary or text file (no
application assigned). Evince reports error "Unable to open document Unhandled
MIME type: 'application/octet-stream'" (even from File->Open menu). In console I
see "I/O error : Permission denied".
After small research I've noticed that Brasero installation caused change in
file permissions in /usr/share/mime directory:

[marcinz@bolger mime]$ pwd
/usr/share/mime
[marcinz@bolger mime]$ ll
total 148
-rw-r----- 1 root root  2393 mar  1 08:10 aliases
drwxr-xr-x 2 root root 12288 mar  1 08:10 application
drwxr-xr-x 2 root root  4096 mar  1 08:10 audio
-rw-r----- 1 root root 14151 mar  1 08:10 globs
drwxr-xr-x 2 root root  4096 mar  1 08:10 image
drwxr-xr-x 2 root root   141 mar  1 08:10 inode
-rw-r----- 1 root root 12617 mar  1 08:10 magic
drwxr-xr-x 2 root root  4096 mar  1 08:10 message
-rw-r----- 1 root root 52272 mar  1 08:10 mime.cache
drwxr-xr-x 2 root root    21 mar  1 08:10 model
drwxr-xr-x 2 root root  4096 mar  1 08:10 multipart
drwxr-xr-x 2 root root  4096 mar  1 08:10 packages
-rw-r----- 1 root root  5794 mar  1 08:10 subclasses
drwxr-xr-x 2 root root  4096 mar  1 08:10 text
drwxr-xr-x 2 root root  4096 mar  1 08:10 video
-rw-r----- 1 root root    56 mar  1 08:10 XMLnamespaces

(08:10 it's the time when I updated brasero package)

Non root users has no access for example to mime.cache.

Call by hand:
update-mime-database /usr/share/mime
helps.

I saw brasero.spec file and I'm not sure what the reason is
("update-mime-database /usr/share/mime" should be run in "post" section).


Version-Release number of selected component (if applicable):
0.5.2-1

How reproducible:
Once when I updated in the morning (via yum).
After downgrade to 0.5.1 and update again to 0.5.2 problem doesn't occour.

Steps to Reproduce:
1. Update brasero to 0.5.2-1
2. Try to use some program which uses mime types.

  
Actual results:
Normal user doesn't see mime-types in a system.

Expected results:
mime-types should work.

Additional info:
I had similar problem at the turn of November and December, but then it took me
some time to find out the reason and I don't know which package broke it down.

Comment 1 Denis Leroy 2007-03-04 11:01:53 UTC
Hi Marcin,

Sorry to sound negative, but I'm having a difficult time either reproducing the
problem, or either see how this could be related to brasero specifically. I just
reviewed the sections of brasero upstream files and SPEC files related to mime
stuff, and it really doesn't do anything out of the ordinary. The mime-specific
sections in the spec file are exactly the same as 20 other extra packages that
do a similar mime installation. Do you have the same problem with one of those
packages (eg audacity, gcdmaster, glom) ?

I'm suspecting that you have some unusal shell setup that might cause this. What
umask do you have setup for you or root ? Did you modify any RPM macro files ?
Anything unusual in bashrc ? Can you reproduce the problem when logged in as
root (using "su -", not just "su") ? Using a different shell (use tcsh or zsh) ?
If yes, feel free to attach the rpmbuild and rpm install log to this bug. If I
don't hear from you, i'll close this bug in a couple of bugs as a 'WORKFORME'.

cheers

Comment 2 Marcin Zajaczkowski 2007-03-06 08:23:36 UTC
I have that problem again. This time (probably) with audacity.

Today I updated two packages audaticy and evolution-data-server (few more was
required by dependecies):
Mar 06 09:02:56 Updated: evolution-data-server.i386 1.8.3-2.fc6
Mar 06 09:02:57 Installed: libfreebob.i386 1.0.0-3.fc6
Mar 06 09:02:59 Installed: jack-audio-connection-kit.i386 0.102.20-3.fc6
Mar 06 09:03:14 Updated: audacity.i386 1.3.2-8.fc6
Mar 06 09:03:29 Updated: evolution-data-server-devel.i386 1.8.3-2.fc6

[marcinz@bolger mime]$ pwd
/usr/share/mime
[marcinz@bolger mime]$ ll
total 148
-rw-r----- 1 root root  2393 mar  6 09:03 aliases
drwxr-xr-x 2 root root 12288 mar  6 09:03 application
drwxr-xr-x 2 root root  4096 mar  6 09:03 audio
-rw-r----- 1 root root 14151 mar  6 09:03 globs
drwxr-xr-x 2 root root  4096 mar  6 09:03 image
drwxr-xr-x 2 root root   141 mar  6 09:03 inode
-rw-r----- 1 root root 12617 mar  6 09:03 magic
drwxr-xr-x 2 root root  4096 mar  6 09:03 message
-rw-r----- 1 root root 52272 mar  6 09:03 mime.cache
drwxr-xr-x 2 root root    21 mar  6 09:03 model
drwxr-xr-x 2 root root  4096 mar  6 09:03 multipart
drwxr-xr-x 2 root root  4096 mar  6 09:03 packages
-rw-r----- 1 root root  5794 mar  6 09:03 subclasses
drwxr-xr-x 2 root root  4096 mar  6 09:03 text
drwxr-xr-x 2 root root  4096 mar  6 09:03 video
-rw-r----- 1 root root    56 mar  6 09:03 XMLnamespaces

Time matches again.

I used pup started from a "pop-up" about pending updates (like last time).

Root doesn't have any additional rpmmacros, default bashrc, bash used as a shell.
[root@bolger ~]# umask
0022

As I said I have problem with reproduction of that bahaviuor on demand. Is there
something more that I could check to facilitate you bug tracking (if it's really
related with your packages)?


Comment 3 Michael Schwendt 2007-03-06 10:31:28 UTC
We're going to use an explicit umask 022 in Audacity rpm's scriptlets,
since installing/removing rpms with a more restrictive umask is the
only way I can reproduce such symptoms.

I suggest the same is done for brasero and any other package which
has scriptlets whose results depend on the umask.

Comment 4 Denis Leroy 2007-05-30 12:33:23 UTC
Fixed as of F-7.