Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 230694

Summary: CIFS PROBLEM WITH WINDOWS 2003 SMALLBUSINESS
Product: [Fedora] Fedora Reporter: bob godwin <bobgodwinx>
Component: kernelAssignee: Jeff Layton <jlayton>
Status: CLOSED CURRENTRELEASE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 5CC: jplans, steved, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: F7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-19 20:46:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description bob godwin 2007-03-02 09:18:57 UTC
Description of problem:

A share mounted using the CIFS mounts correctly.  Files can be viewed or listed
but cannot read, open 0r copy files.  Kernel dmesg log reports only:  
"CIFS VFS: Send error in read = -13"
Version-Release number of selected component (if applicable):
$ uname -r
2.6.17-1.2174_FC5smp
Steps to Reproduce:
1. mount.cifs //192.168.XXX.XX/share /win2003server -o
username=user,password=passwd 
2. cd /win2003server
3. cp -dpR filename.txt /z/ -v
  
Actual results:

$ cp filename.txt
cp: two filename.txt: Permission denied

Expected results:

$ cp filename.txt
[file contents here...]

Additional info:
Samba 3.0.23b. did not resolve this problem. Note in fedora core 3 & 4 the above 
CIFS works pretty well. This problem is also repeated not only in fedora core 5
but also in fedora core 6 zod. it is a problem with the WINDOWS 2003
SMALLBUSINES SERVER. With other windows operating systems it works perfectly.

Comment 1 Simo Sorce 2007-03-02 16:38:53 UTC
Samba provides only the user space mount helper, if mount is fine, then the bug
must be in the CIFS Kernel module (as the CIFS VFS log line seem to imply).

Reassigning bug to kernel.

Comment 2 Chuck Ebbert 2007-03-02 16:57:26 UTC
Try a newer kernel. 2.6.19-1.2288.2.1 should be out any minute now.

Comment 3 bob godwin 2007-03-02 21:52:11 UTC
l'm always afraid to modify kernel because the last time l applied a patch it 
took me 5hrs to restore the whole system. So l took the other way round by 
modifying the windows 2003 server registry to allow SMB BLOCK in the access 
control. for now it works fine but not a good idea for security reasons. Hope 
this will be resolved with fedora core 7.  

Comment 4 bob godwin 2007-03-02 21:52:41 UTC
l'm always afraid to modify kernel because the last time l applied a patch it 
took me 5hrs to restore the whole system. So l took the other way round by 
modifying the windows 2003 server registry to allow SMB BLOCK in the access 
control. for now it works fine but not a good idea for security reasons. Hope 
this will be resolved with fedora core 7.  

Comment 5 Jeff Layton 2007-11-18 12:59:29 UTC
Is this still an issue on F7 or F8?


Comment 6 bob godwin 2007-11-19 20:27:14 UTC
No in Fedora 7 it is completely possible to do mounts with CIFS without
problems. I haven't tried Fedora 8 yet. 

Comment 7 Jeff Layton 2007-11-19 20:46:18 UTC
Good. I'll close this as CURRENTRELEASE then. Please reopen if you find it to
still be an issue.