Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 230056

Summary: Latest fedora-logos requires 20 new unnecessary packages
Product: [Fedora] Fedora Reporter: Jarkko <jval>
Component: fedora-logosAssignee: David Zeuthen <davidz>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dgunchev, mclasen, smagoun
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-17 06:27:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jarkko 2007-02-26 11:50:51 UTC
Description of problem: Latest fedora-logos in the development repository adds
requirements for all kinds of libraries. The package contains only images, so
clearly it should not require any libraries. What makes this really annoying is
that most of those libraries are X related. I *really* don't want to install all
those X related libraries to my minimalized Xen Domain-0 host.

Version-Release number of selected component (if applicable): 6.0.93-1.fc7

How reproducible: Always

Steps to Reproduce:
1. Use Rawhide with fedora-logos < 6.0.93-1.fc7
2. Run "yum upgrade"
3. See the suggested package list
  
Actual results:

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 fedora-logos            noarch     6.0.93-1.fc7     development       5.7 M
Installing for dependencies:
 atk                     x86_64     1.17.0-1.fc7     development       233 k
 cairo                   x86_64     1.3.14-1.fc7     development       385 k
 cups-libs               x86_64     1:1.2.8-1.fc7    development       178 k
 fontconfig              x86_64     2.4.2-2.fc7      development       178 k
 freetype                x86_64     2.3.1-1.fc7      development       319 k
 gnutls                  x86_64     1.4.5-1          development       363 k
 gtk2                    x86_64     2.10.9-4.fc7     development       6.6 M
 gtk2-engines            x86_64     2.9.3-2.fc7      development       389 k
 hicolor-icon-theme      noarch     0.10-1           development        32 k
 libXcursor              x86_64     1.1.8-1          development        32 k
 libXfixes               x86_64     4.0.3-1          development        15 k
 libXft                  x86_64     2.1.12-1.fc7     development        44 k
 libXi                   x86_64     1.0.2-1          development        29 k
 libXinerama             x86_64     1.0.1-2.1        development        10 k
 libjpeg                 x86_64     6b-37            development       140 k
 libpng                  x86_64     2:1.2.16-1.fc7   development       237 k
 libthai                 x86_64     0.1.7-5.fc7      development       153 k
 libtiff                 x86_64     3.8.2-7.fc7      development       318 k
 pango                   x86_64     1.15.6-1.fc7     development       357 k
 redhat-artwork          x86_64     5.0.10-1.fc7     development       5.3 M

Transaction Summary
=============================================================================
Install     20 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 21 M
Is this ok [y/N]: n

Expected results:

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 fedora-logos            noarch     6.0.93-1.fc7     development       5.7 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 5.7 M
Is this ok [y/N]: y

Additional info: I *really* hope those new dependencies were added accidentally.
I don't want to install X related packages to this system. :)

Comment 1 Matthias Clasen 2007-02-27 06:34:29 UTC
Pendantic directory ownership rules require these dependencies.

Comment 2 Jarkko 2007-02-27 12:02:55 UTC
You should distribute the logos more targeted.

There is an easy solution to this problem: Create subpackages in the spec files;
one subpackage for each package (or package group) which uses the logos. Then
make the depending packages to require the subpackage instead of the whole
fedora-logos or redhat-artwork.

At least redhat-artwork should be split I guess because that brings e.g. gtk2 to
the list.

Comment 3 Jarkko 2007-03-05 08:08:25 UTC
I have a really easy (and also good, I think) solution to this problem.

I bet all the other logos are related to a graphical environment (they are logos
after all), except: /boot/grub/splash.xpm.gz

I think with graphical environment those new dependencies are acceptable because
you would have those packages installed anyway (e.g. you will end up with gtk2
anyway because Fedora tools use that).

Just distribute that one (/boot/grub/splash.xpm.gz) separated, and at least my
system would be fine with those new dependencies - because then I can remove
fedora-logos as an unnecessary package (this is not a graphical system).

Solution: Create a subpackage called fedora-logos-grub which provides
grub-splash. Then change grub to require grub-splash instead of system-logos.

Comment 4 Matthias Clasen 2007-03-24 05:30:23 UTC
having all trademarked fedora logos in a single package is a requirement from RH
legal.

Comment 5 Jarkko 2007-03-24 09:07:19 UTC
In a single binary package? Or just source? My suggestion still keeps everything
in one source package.

Comment 6 Doncho Gunchev 2007-04-30 11:19:02 UTC
I don't like the situation too:

  - Why a minimal non-GUI system (i.e. simple router/firewall) should have
fedora-logos (and GTK and...) installed for of grub? Grub works just fine
without any logo (but 'rpm -e --nodeps --force fedora-logos' is much more wrong).

  - Why a KDE only desktop (just hypothetically, I always have KDE, GNOME,
XFCE4... installed) have GTK and so on installed? If/when system-config-* get
ported to KDE...

  Does one source package solve the legal problem (I hope so, good idea Jarkko)?

Comment 7 Matthias Clasen 2007-06-17 06:27:46 UTC
* Fri Jun 15 2007 Adam Jackson <ajax@redhat.com> 6.0.98-4
- Remove the Requires on redhat-artwork and fedora-icon-theme, and just
  multi-own the directories.  Fixes some hilarious dependency chains.