Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 230020

Summary: Weird stuff with icons
Product: [Fedora] Fedora Reporter: Konrad Kosmowski <konrad>
Component: claws-mailAssignee: Andreas Bierfert <andreas.bierfert>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 2.8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-28 08:49:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Konrad Kosmowski 2007-02-25 23:40:36 UTC
Description of problem: When you launch Claws Mail (for other than first time)
it is missing icons in folder pane.

Version-Release number of selected component (if applicable): claws-mail-2.7.2-1.fc6

How reproducible: (In my system) Always

Steps to Reproduce:
1. Launch Claws Mail
2. Close it
3. Launch it again and observe folder pane - icons not show up.
  
Actual results: Folder icons do not show up (see att 1)
http://home.kosmosik.net/always/sc_actual.jpg

Expected results: Folder icons to show up (see att 2)
http://home.kosmosik.net/always/sc_expected.jpg

Additional info: Tested on only one system so maybe it is only my config. But
still it is perfectly healthly install and it should work. I don't know if it is
actual code or some packaging/dependecy problem so I post it here and let the
maintainer do upstream if it is required.

Comment 1 Andreas Bierfert 2007-02-27 16:15:14 UTC
Hm I cannot reproduce this here at all tough your theme looks different from the
default theme... Did you install any additional themes which might cause these
problems?

Comment 2 Konrad Kosmowski 2007-02-27 23:26:35 UTC
Well it is something with mine particular setup. I did:

1. Moved config files somwhere else - started with clear profile. The bug didn't
show up.

2. Set (using my usual settings) theme to standard one. Deleted the custom one
I've made. Closed Claws, opened it again and the bug occured with default built
in theme.

The theme I've compiled is here:
https://kosmosik.net/_media/files/kosmosik-200702280016.tar.gz?id=it%3Akosmosik_claws-mail&cache=cache

Comment 3 Andreas Bierfert 2007-02-28 08:49:47 UTC
My advice would be to take this upstream. The claws-mail guys are really nice
(and fast) about such things. I personaly don't know much about the theming
stuff so they should be able to tell you if it is a bug in your theme or if it
is a bug in theme support.

Comment 4 Konrad Kosmowski 2007-02-28 10:43:34 UTC
Posted upstream:
http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=1128

Comment 5 Konrad Kosmowski 2007-03-01 12:18:39 UTC
Fixed with current (2.8) release.