Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 229905

Summary: gnome-system-log: copy copies wrong lines when log is filtered
Product: [Fedora] Fedora Reporter: Scott Douglass <scott>
Component: gnome-utilsAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7CC: belegdol
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-25 23:50:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Scott Douglass 2007-02-24 02:04:14 UTC
Description of problem:
With a filter applied, the text copied from the gnome-system-log log viewing
window is not the text selected.

Version-Release number of selected component (if applicable):
gnome-utils-2.16.0-1.fc6.src.rpm

How reproducible:
Every time.

Steps to Reproduce:
1.Open the gnome-system-log application.
2.View /var/log/messages.
3.Enable the filter, and enter "kernel" in the filter input widget.
4.Copy some lines from the log and paste them into gedit.
5.Be surprised when what you see is not what you selected in gnome-system-log.
  
Actual results:
Copies lines of the log file that are not the ones selected.

Expected results:
Expected to copy visibily selected lines from the particular log.

Additional info:

Comment 1 Julian Sikorski 2007-06-21 10:45:15 UTC
Still present in f7, gnome-utils-1:2.18.1-1.fc7. My guess is that the line
numbers are taken from filterd output, but absolute ones are copied.

Comment 2 Matthias Clasen 2007-06-21 13:53:04 UTC
Corresponding upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=343215

Comment 3 Julian Sikorski 2007-06-21 13:57:51 UTC
Shall we close this one as upstream then?

Comment 4 Matthias Clasen 2007-06-25 23:50:00 UTC
We could certainly do that, since I doubt that we are going to fix this
independent from upstream.