Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 229783

Summary: ip_gre module not autoloaded on demand
Product: [Fedora] Fedora Reporter: Tethys <tethys>
Component: module-init-toolsAssignee: Jon Masters <jcm>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-02 21:57:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tethys 2007-02-23 14:37:20 UTC
Description of problem:

leto:~# ip tunnel add foo mode gre local 1.1.1.1 remote 2.2.2.2
ioctl: No such device
leto:~# modprobe ip_gre
leto:~# ip tunnel add foo mode gre local 1.1.1.1 remote 2.2.2.2
leto:~# 

Version-Release number of selected component (if applicable):
module-init-tools-3.3-0.pre1.4.17

How reproducible:
Every time

Additional info:
Adding "alias gre0 ip_gre" to /etc/modprobe.conf fixes this. I can't think
of a valid reason for it not to be there by default.

Comment 1 Tethys 2007-02-23 14:42:20 UTC
*** Bug 229784 has been marked as a duplicate of this bug. ***

Comment 2 Jon Masters 2007-08-20 06:16:26 UTC
Hmmm. I guess it's ok to do this. I'll think about it.

Jon.