Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 229574

Summary: Anaconda bombs with a SIGSEGV when run with the noipv6 boot option
Product: Red Hat Enterprise Linux 5 Reporter: Steve Salevan <ssalevan>
Component: anacondaAssignee: David Cantrell <dcantrell>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-06 21:04:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Steve Salevan 2007-02-21 21:15:42 UTC
Description of problem:
If a user attempts to disable IPv6 via attaching the 'noipv6' boot option,
anaconda tries to claim a dynamic IP without using IPv6.  However, halfway
through doing this, anaconda bombs with the following output:

loader received SIGSEGV!  Backtrace:
[0x8048284]
[0x426420]
[0x818d2f3]
[0x805f2dc]
[0x8066b9b]
[0x8066ccb]
[0x8067167]
[0x80665cd]
[0x805e510]
[0x805e880]
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
	/proc done
	/dev/pts done
	/sys done
	/tmp/ramfs done
you may safely reboot your system

Version-Release number of selected component (if applicable):
RHEL 5 Gold

How reproducible:
Always (at least when I try it)

Steps to Reproduce:
1. Start a RHEL 5 installation via CD or kickstart and ensure that the 'noipv6'
option is tagged onto the boot line.
2. Wait until Anaconda loads and watch it when it attempts to grab a dynamic IP
  
Actual results:
Anaconda bombs as above

Expected results:
Anaconda locates an IP within a reasonable amount of time and proceeds with the
installation

Additional info:
This error was encountered on a VMware box and the RHEL 5 Gold installation was
initiated via an RHN Satellite-based kickstart.

Comment 1 David Cantrell 2007-03-06 21:04:54 UTC
I can't reproduce this with RHEL-5 GOLD on either real hardware or VMware.  DHCP
works fine when you pass the 'noipv6' argument at boot time.