Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 229489

Summary: include/asm-i386/tsc.h includes asm-x86_64/tsc.h ?!?!
Product: [Fedora] Fedora Reporter: Tom London <selinux>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: high    
Version: rawhideCC: dwmw2, gauret, masami.hiramatsu, mingo, netllama, notting, sangu.fedora, ville.skytta, vonbrand, wcohen, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-03 18:16:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tom London 2007-02-21 15:10:40 UTC
Description of problem:
Running kernel-PAE-2.6.20-1.2936.fc7; kernel-headers links asm-i386/tsc.h to
nonexistant asm-x86/tsc.h

I copied asm-i386/tsc.h from 2.6.20-1.2932 to asm-i386/tsc.h and all appears to
work.

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.20-1.2936.fc7

How reproducible:
Every time!

Steps to Reproduce:
1. yum update
2. ....
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2007-02-21 15:49:19 UTC
Sorry, typo.... tries to include asm-x86_64/tsc.h

Comment 2 Aurelien Bompard 2007-02-22 22:31:43 UTC
I confirm this (FWIW)

Comment 3 sangu 2007-02-23 12:14:59 UTC
This problem still happens in kernel-2.6.20-1.2940.fc7.
See Also : http://bugzilla.livna.org/show_bug.cgi?id=1419

Comment 4 David Woodhouse 2007-02-23 12:20:48 UTC
At first glance (after fixing the typo in the summary) it looks like the fix
would be to swap the files round and include the i386 one from x86_64 instead --
but on closer inspection I don't actually see what in there is supposed to be
visible to userspace anyway.

Comment 6 Tom London 2007-02-23 14:29:00 UTC
Yeah, sorry.

Fails for rebuild of ipw3945 module, vmware modules, etc.

Comment 7 Chuck Ebbert 2007-02-24 16:38:11 UTC
We need to fix this before the FC6 2.6.20 kernel is released.
Can we just add the whole asm-x86_64 directory to the devel package
as a workaround?


Comment 8 Stewart Adam 2007-02-24 17:39:11 UTC
I can confirm, too - nvidia modules won't build.

Comment 9 Ville Skyttä 2007-02-25 08:57:43 UTC
Me too, with 2.6.20-1.2942.fc7.  By the way, it's not only the PAE kernel-devel
nor only tsc.h, regular i586 and i686 kernel-devels have this too and some other
x86_64 includes, this is from the i686 include dir for 2942:

$ grep -r -- "#include.*x86_64" *
asm/stacktrace.h:#include <asm-x86_64/stacktrace.h>
asm/tsc.h:#include <asm-x86_64/tsc.h>
asm/k8.h:#include <asm-x86_64/k8.h>
asm/pci-direct.h:#include "asm-x86_64/pci-direct.h"
asm-i386/stacktrace.h:#include <asm-x86_64/stacktrace.h>
asm-i386/tsc.h:#include <asm-x86_64/tsc.h>
asm-i386/k8.h:#include <asm-x86_64/k8.h>
asm-i386/pci-direct.h:#include "asm-x86_64/pci-direct.h"


Comment 10 Masami Hiramatsu 2007-02-25 12:55:37 UTC
I confirmed, too.
SystemTap can't run any script on kernel-2.6.20-1.2942.fc7.


Comment 11 Dave Jones 2007-02-26 06:02:53 UTC
*** Bug 230031 has been marked as a duplicate of this bug. ***

Comment 12 Dave Jones 2007-02-27 01:53:40 UTC
*** Bug 230176 has been marked as a duplicate of this bug. ***

Comment 13 Stewart Adam 2007-02-27 15:23:27 UTC
For now why don't we just replace tsc.h with the tsc.h from 2.6.20-1.2932 which
doesn't have this bug? I can provide a patch if needed.

Comment 14 Tom London 2007-03-03 18:16:20 UTC
Working in .2960 and .2962.

Closing.