Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 229389

Summary: Library issues with nxrun
Product: [Fedora] Fedora Reporter: Gwyn Ciesla <gwync>
Component: freenxAssignee: Axel Thimm <axel.thimm>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-03 08:24:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gwyn Ciesla 2007-02-20 19:55:23 UTC
Description of problem:
limb@HOSTNAME config]$ nxrun REMOTEHOST.conf -u limb -p OBSCURED
I> REMOTEHOST.conf.
I> nxc client library version 1.3.1-1.
redirecting stdout
redirecting stderr
FILE: /home/limb/.nx/temp/31875/sshlog
I> Connecting to 'REMOTEHOST.fqdn'.
Error: libcrypto.so.0.9.8: cannot open shared object file: No such file or
directory.
E> Error: libcrypto.so.0.9.8: cannot open shared object file: No such file or
directory.
I> Error occurred. For more info check '/home/limb/.nx/temp/31875/sshlog'.


Version-Release number of selected component (if applicable):
freenx-0.5.0-5.fc6



How reproducible:
Attempt connection to freeNX server using nxrun client or nxrun-gui.py(from berlios)

Steps to Reproduce:
See above
  
Actual results:
See above

Expected results:
NX session

Additional info:

Comment 1 Axel Thimm 2007-05-19 14:24:04 UTC
This is a collective bugzilla comment for nx/freenx bugs.

New versions of nx and freenx have entered the repos. Please check if the bug
report is still valid with the new versions (freenx-0.6.0-12 and nx-2.1.0-19).

Comment 2 Gwyn Ciesla 2007-05-21 15:29:50 UTC
I installed the latest nx from fc6 and the freenx from f7, as that's what's in
the mirrors.

./nxrun: error while loading shared libraries: libstdc++.so.5: cannot open
shared object file: No such file or directory

Looks like it wants an older version of libstcc++.

I can't find the source for nxrun to rebuild it.  I'm just looking for a way to
connect to a remote freenx server, and the graphical clients are either stalled
(knx, qtnx) or closed (nomachine).

Training issue?

Comment 3 Gwyn Ciesla 2007-05-21 16:30:02 UTC
And now I can't connect to my freenx server with the nomachine client.  Says
it's missing /usr/libexec/nx/nxagent.

Looks like the path changed from /usr/libexec/nx/nxserver, and the rpm didn't
update the nx user to use the new /usr/bin/nxserver path.

I can't use the new version at all, and I have to manually correct the nx user
shell path when I revert.

Comment 4 Axel Thimm 2007-05-21 17:09:55 UTC
(In reply to comment #1)
> New versions of nx and freenx have entered the repos. Please check if the bug
> report is still valid with the new versions (freenx-0.6.0-12 and nx-2.1.0-19).

Looks like they are still waiting in the queue. Use rpm -q nx freenx to check
whether you already got the right packages.

(In reply to comment #2)
> ./nxrun: error while loading shared libraries: libstdc++.so.5: cannot open
> shared object file: No such file or directory

Where did you get nxrun from? It isn't part of nx or freenx and if it doesn't
pull in the dependencies proper it needs to be fixed from the packager.

Comment 5 Gwyn Ciesla 2007-05-21 17:15:08 UTC
I verified the versions, my mirror doesn't have the newest freenx for fc6 yet.

nxrun is from http://freenx.berlios.de/, and is a precompiled binary to which I
cannot find source.

At this point, I'd forget about the library issue and follow the user shell path
problem.

Comment 6 Axel Thimm 2007-06-03 08:24:19 UTC
OK, I suggest to close this bug then, as it primarily refers to nxrun and open a
new one for the shell issue if this is still an issue.

freenx has the following code:

/usr/sbin/useradd -r -d /var/lib/nxserver/home -s /usr/libexec/nx/nxserver nx
2>/dev/null \
  || /usr/sbin/usermod -d /var/lib/nxserver/home -s /usr/libexec/nx/nxserver nx
2>/dev/null || :

Which should ensure that the nx user's shell is properly set. If not, please
open a new bug, thanks!