Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 229356

Summary: Eclipse autotools plugin does a make clean when opening a project
Product: [Fedora] Fedora Reporter: Jordy Potman <redhat-bugzilla>
Component: eclipse-cdtAssignee: Jeff Johnston <jjohnstn>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-21 15:05:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jordy Potman 2007-02-20 16:20:09 UTC
The Eclipse autotools plugin performs a make clean when opening a project, even
if the project hasn't changed since the last time it was opened. This is kind of
annoying on larger projects because they have to be completely rebuild every
time you close and later reopen a project.

I have had a quick look at the sources but I don't know enough about Eclipse to
figure out where this make clean is started from.

This is on an eclipse.org Eclipe Version: 3.2.0 Build id: M20070212-1330, with
CDT 3.1.2. The autotools plugin is from sources.redhat.com CVS.
org.eclipse.cdt.core, org.eclipse.cdt.managedbuilder.core and org.eclipse.cdt.ui
are from the cdt_3_1 branch from eclipse.org CVS with the autotools plugin
patches applied.

Comment 1 Andrew Overholt 2007-02-20 16:23:51 UTC
I thought Jeff had fixed this.  Jeff?

Jordy:  please file these against eclipse-cdt.

Comment 2 Jeff Johnston 2007-02-20 21:13:30 UTC
Autotools sits on top of the ManagedMake plug-in.   A fix was put in place for
general building where "build project" was always invoking a clean ahead of
"all".  I hadn't tested it with closing/reopening a project, but just did so
with my local check-out and it worked fine.  Could you please attempt to update
your sources and try again?  The fix was put in 01/26/2007 and was built into
the Fedora eclipse-cdt-3.1.1-8 for FC6.

Comment 3 Jordy Potman 2007-02-21 15:05:19 UTC
I figured out why it wasn't working for me. It is caused by a conflict with the
PDT feature ( http://download.eclipse.org/tools/php/updates/ ) from the PHP
Development Tools project ( http://www.eclipse.org/php/ ). If I disable the PDT
feature my autotools projects don't get make cleaned anymore every time I close
and reopen them. I don't know yet why the PDT feature is causing the make clean.

Thanks a lot for creating the autotools plugin. Now that I've got it working
properly it is going to be really useful.