Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 229230

Summary: gphoto2 can stop manage permissions now
Product: [Fedora] Fedora Reporter: David Zeuthen <davidz>
Component: gphoto2Assignee: Jindrich Novy <jnovy>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: mclasen, pknirsch
Target Milestone: ---Keywords: EasyFix, Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-21 11:19:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150226    

Description David Zeuthen 2007-02-19 17:25:28 UTC
We've moved ACL handling into HAL proper with hal-0.5.9-0.git20070218. So this
file and the associated binaries should be removed

 /usr/share/hal/fdi/policy/20thirdparty/90-gphoto-camera-policy.fdi

Thanks.

Comment 1 Jindrich Novy 2007-02-19 19:17:46 UTC
Happily removed.

Comment 2 David Zeuthen 2007-02-19 19:29:11 UTC
Thanks - but you removed a bit too much; this file

 /usr/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi

is still needed since it's used to classify USB interfaces as being cameras.
Without this HAL won't know the USB device is a camera. Thanks.


Comment 3 David Zeuthen 2007-02-19 19:30:22 UTC
I meant

  /usr/share/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi

of course.

Comment 4 Jindrich Novy 2007-02-21 11:19:26 UTC
10-camera-libgphoto2.fdi is now added back.

Comment 5 Andreas Heik 2007-11-26 12:34:58 UTC
Today, there are 2 problems with gphoto2 and acl-management in Fedora 8.

First, the hal-rule for "main usb devices" into
/usr/share/hal/fdi/policy/10osvendor/20-acl-management.fdi begin at line 61 will
not match.
My Device (Canon PowerShot S45) returns info.subsystem = 'usb_device'  (string).
Is the rule <match key="info.subsystem" contains="usb"> better at this line??

The second problem is the fdi-information file into gphoto2-package.
Checking for usb-bus works only with string="usb_device" or contains="usb". 
If the device has no key "usb.interface_class", all camara-rules will be
skipped. I think there is no need for skipping usb storage devices or we need a
better determination rule.
At least, the keys "usb.vendor_id", "usb.product_id" are changed to
"usb_device.vendor_id", "usb_device.product_id"

best regards, andreas