Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 229096

Summary: hidd causing a kernel oops
Product: [Fedora] Fedora Reporter: Patrick <rh_bugzilla>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dwmw2, marcel, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-13 16:24:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Patrick 2007-02-16 23:17:09 UTC
Description of problem:
Kernel oops, bluetooth mouse stops working. When shutting down, "stopping hidd"
hangs. (not sure if I am correct in blaming hidd from bluez-utils. Maybe it's a
kernel bug in which cause please correct).

Version-Release number of selected component (if applicable):
kernel-devel-2.6.20-1.2930.fc7.i686
bluez-utils-3.9-1.fc7.i386

How reproducible:
Wait for it to happen. Seen it happen twice with yum -y update. Have also seen
it happen several times when the blank screen + lock had kicked in and I enter
the password to unlock the screen

Steps to Reproduce:
1. start laptop
2. wait for it to happen
3. kernel oops
  
Actual results:
Kernel oops, bluetooth mouse stops working, stopping the hidd service when
shutting down hangs forever.

Expected results:
No kernel oops, working bluetooth mouse.

Additional info:
Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: Oops: 0000 [#1]

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: SMP 

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: CPU:    0

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: EIP:    0060:[<c04eb036>]    Tainted: P       VLI

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: EFLAGS: 00010286   (2.6.20-1.2932.fc7 #1)

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: EIP is at kobject_get_path+0x20/0x9a

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: eax: 00000000   ebx: c6fb725a   ecx: ffffffff   edx: 000000d0

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: esi: e29bf890   edi: 6b6b6b6b   ebp: e594ee98   esp: e594ee7c

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: ds: 007b   es: 007b   ss: 0068

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: Process khidpd_04580058 (pid: 4735, ti=e594e000 task=ebd00030
task.ti=e594e000)

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: Stack: e594ee9c e29bf890 00000001 c04eb055 c6fb725a e29bf7b8
f7e8acb0 e594eed8 

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:        c055dee8 0046510d 00000246 ffffffff fffffffe ffffffff
00000000 c06ad917 

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:        c6fb722e e2929020 00000000 00000000 c6fb725a 00000006
c055deab e594ef2c 

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: Call Trace:

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c04051c9>] show_trace_log_lvl+0x1a/0x2f

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c0405279>] show_stack_log_lvl+0x9b/0xa3

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c0405415>] show_registers+0x194/0x26a

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c0405618>] die+0x12d/0x242

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c06118f7>] do_page_fault+0x3ee/0x4ba

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c06100f4>] error_code+0x7c/0x84

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c055dee8>] class_uevent+0x3d/0x1dc

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c04eba54>] kobject_uevent_env+0x21a/0x412

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c04ebc56>] kobject_uevent+0xa/0xc

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c055d844>] class_device_del+0x11a/0x138

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c055d86d>] class_device_unregister+0xb/0x15

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c05866c0>] input_unregister_device+0x116/0x13e

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<f91a205c>] hidp_session+0x411/0x435 [hidp]

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  [<c0404cb3>] kernel_thread_helper+0x7/0x10

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel:  =======================

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: Code: 90 55 89 e5 e8 1c aa f8 ff 5d c3 55 89 e5 57 56 89 c6 53 83
ec 10 89 45 e8 c7 45 ec 01 00 00 00 8b 3e 85 ff 74 73 31 c0 83 c9 ff <f2> ae f7
d1 49 8b 45 ec 8d 44 08 01 89 45 ec 8b 76 24 85 f6 75 

Message from syslogd@speedy at Fri Feb 16 20:36:06 2007 ...
speedy kernel: EIP: [<c04eb036>] kobject_get_path+0x20/0x9a SS:ESP 0068:e594ee7c

Comment 1 David Woodhouse 2007-02-18 10:26:36 UTC
Sysfs b0rkage. I think this is what I've seen ever since we turned on
CONFIG_SYSFS_DEPRECATED in 2.6.19-1.2914.fc7

Comment 2 Patrick 2007-03-02 15:03:12 UTC
The problem is still present in the 2.9.20-1.2960.fc7 kernel. The easiest way to
reproduce this  issue consistently is to the set screensaver mode to blank
screen+lock and let it kick in. Log in and check /var/log/messages for the info
about the kernel oops. The bluetooth mouse no longer works until I reboot.

Comment 3 Patrick 2007-03-02 15:49:39 UTC
Seems you don't even need to have the screen lock when the screensaver kicks in.
Without the screen lock after the screensaver has kicked in the kernel oops
happens just as reliable :(  Hope this helps in tracking down the issue. If you
need more info please let me know.

Comment 4 Patrick 2007-03-13 14:29:56 UTC
The problem is still present with today's Rawhide and kernel 2.6.20-1.2985.fc7

Comment 5 David Woodhouse 2007-03-13 16:24:25 UTC

*** This bug has been marked as a duplicate of 227893 ***