Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 229090

Summary: LVM appears to be off by 1 extent, meaning reusing an existing VG is impossible
Product: [Fedora] Fedora Reporter: Zack Cerza <zcerza>
Component: anacondaAssignee: Peter Jones <pjones>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: triage
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-24 16:49:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 217913    
Bug Blocks:    

Description Zack Cerza 2007-02-16 21:50:42 UTC
+++ This bug was initially created as a clone of Bug #217913 +++

Description of problem:
I want to install F7T1 over FC6 on my laptop, preserving /home but wiping /.
Both partitions are under LVM. When I tried setting this up manually, anaconda
complained about not having enough space in the VG; in fact, it said the VG had
-32MB free space, which is the size of one extent. See the attached screenshot.

I don't know of any other way to install without wiping /home, other than trying
to tell anaconda not to format /, which may or may not work around this problem.

-- Additional comment from zcerza@redhat.com on 2006-11-30 14:04 EST --
Created an attachment (id=142505)
screenshot


-- Additional comment from mhild@redhat.com on 2006-12-01 12:32 EST --
Same for me.
I got arround the issue by resizing swap, which was also in LVM

-- Additional comment from rkenna@redhat.com on 2006-12-09 00:28 EST --
Pretty ugly.  pn-ack

-- Additional comment from pjones@redhat.com on 2006-12-12 17:45 EST --
Is this still happening?  If so, can you show me how to reproduce it?

-- Additional comment from pjones@redhat.com on 2006-12-12 19:07 EST --
Aha, you've got to start with a much older set of LVs.

-- Additional comment from pjones@redhat.com on 2006-12-12 19:53 EST --
Should (hopefully) be fixed in the next anaconda build.  Upgrades from RHEL4 and
new installs need to both be tested, and "lvm pvs" needs to be run after each to
make sure there's no unrequested free space left on any physical volumes.

-- Additional comment from pm-rhel@redhat.com on 2007-02-07 20:08 EST --
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Comment 1 Jeremy Katz 2007-02-26 19:45:20 UTC
So the clone bits are confusing here... what exactly are you trying to say Zack? :)

Comment 2 Zack Cerza 2007-02-26 20:04:10 UTC
I have an existing LVM VG with separate boot, root and home partitions. I want
to install F7 on the disk, wiping out my old FC6 install, but I want to keep my
home partition intact. Anaconda won't let me, saying there isn't enough room for
all my volumes. It says there is -32MB (or -1 extent) free. 

Since the volumes exist and function just fine, I'm guessing anaconda (or lvm,
whoever this error really comes from) is wrong.

Comment 3 Bill Nottingham 2007-03-02 17:33:23 UTC
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.

Comment 4 Zack Cerza 2007-03-26 22:02:16 UTC
Will this be able to be fixed for F7? We did fix it in RHEL5, didn't we?

Comment 5 Bug Zapper 2008-04-03 19:10:33 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 6 Joel Andres Granados 2008-04-24 16:49:57 UTC

*** This bug has been marked as a duplicate of 428756 ***