Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 228892

Summary: highly repeatable crash, unknown trigger
Product: [Fedora] Fedora Reporter: David Nielsen <gnomeuser>
Component: gaimAssignee: Warren Togami <wtogami>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: eblanton, fedora, lschiere+bugs, marius.andreiana, mark, redhat-bugzilla, stu, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-19 04:47:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150226    
Attachments:
Description Flags
backtrace none

Description David Nielsen 2007-02-15 19:27:38 UTC
Description of problem:
I'm seeing a regular crash but I can't for my life find a way to provoke it.
I've attached a backtrace in the hope that you might be able to work out what
makes it happen.

It always seems to happen when receiving a message but with no regularity I have
been able to figure out.

Version-Release number of selected component (if applicable):
gaim-2.0.0-0.30.beta6.fc7

Comment 1 David Nielsen 2007-02-15 19:27:39 UTC
Created attachment 148138 [details]
backtrace

Comment 2 Thorsten Leemhuis 2007-03-13 09:30:26 UTC
Seeing something like this, too. 

Comment 3 Ethan Blanton 2007-03-13 14:31:54 UTC
This looks like it might be a bad gstreamer interaction, and the sound playing
is causing the crash, but it's really not clear.  I see that you're doing some
conversions from ISO-8859-1; what protocol is this?  I can't tell from the
backtrace, unless I'm overlooking something.  If you're using more than one, can
you try signing on one at a time until the problem shows itself, so we can
narrow down where it's being triggered?

Comment 4 David Nielsen 2007-03-13 14:41:54 UTC
This would be MSN, it's the only protocol enabled.

Comment 5 Thorsten Leemhuis 2007-03-13 14:59:02 UTC
(In reply to comment #4)
> This would be MSN, it's the only protocol enabled.

In my case it's Jabber and ICQ.

/me puts "capture backtrace from those randon gaim crashes" on his todo-list

Comment 6 Will Woods 2007-04-19 00:53:40 UTC
Any progress on this? Still reproducible with more recent (beta7) versions of
gaim/pidgin?

Comment 7 David Nielsen 2007-04-19 03:07:44 UTC
I haven't seen this one in a while. Thorsten are you still experiencing the joy
and wonder of this very bug?

Comment 8 Thorsten Leemhuis 2007-04-19 04:47:12 UTC
(In reply to comment #7)
> Thorsten are you still experiencing the joy
> and wonder of this very bug?

No. I'd say we close this then for now and reopen if it should happens again.