Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 228818

Summary: No longer works on devices which doesn't support SETTRIGGER
Product: [Fedora] Fedora Reporter: Pierre Ossman <pierre-bugzilla>
Component: audacityAssignee: Gérard Milmeister <gemi>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-15 21:16:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pierre Ossman 2007-02-15 10:23:53 UTC
It seems that though the audacity spec file seems to indicate that PortAudio v18
should be used by default, it is in fact v19 that is used in the currently built
package. And because of bugs in v19, devices which do not support SETTRIGGER do
not work.

Comment 1 Gérard Milmeister 2007-02-15 18:43:55 UTC
I made audacity compile against portaudio v18 from Extras. Could there be any
negative effects from using v18 instead of v19?

Comment 2 Pierre Ossman 2007-02-15 19:45:58 UTC
No idea. I'm more of a casual user. :)

Comment 3 Gérard Milmeister 2007-02-15 21:16:52 UTC
Well, I decided to leave portaudio v19 in. However, now the alsa devices are
properly supported. I also compiled with jack support. 

Comment 4 Michael Schwendt 2007-02-15 22:19:00 UTC
This needs "BuildRequires: alsa-lib-devel".

Comment 5 Gérard Milmeister 2007-02-15 22:51:00 UTC
ok.