Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 228718

Summary: Beagle consumes all free space in /tmp
Product: [Fedora] Fedora Reporter: Michel Alexandre Salim <michel.salim>
Component: beagleAssignee: Alexander Larsson <alexl>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: fche
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-23 04:46:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 150226    

Description Michel Alexandre Salim 2007-02-14 16:47:29 UTC
Description of problem:
Beagle would consume all space in /tmp when indexing.

Version-Release number of selected component (if applicable):
beagle-0.2.16-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Install beagle
2. Wait for it to start indexing

  
Actual results:
Here is the culprit in /tmp:
> ls -lrS | tail -n 1
-rw------- 1 michel michel 8633151488 2007-02-14 02:09 tmp536a4ab4.tmp

> lsof tmp536a4ab4.tmp
COMMAND   PID  USER   FD  TYPE DEVICE SIZE       NODE    NAME
beagled-h 3530 michel 35w  REG 253,0  8633151488 1903290 tmp536a4ab4.tmp

The process had to be killed with -9, and it took minutes for the space to be
fully released

Expected results:
Beagle should consume a sane amount of disk space

Additional info:
I have a 500GB external hard drive mounted, and there are symlinks to it from
$HOME (Music -> /media/external/Music, Movies -> /media/external/Videos, etc)

Comment 1 Frank Ch. Eigler 2007-02-14 23:26:42 UTC
See also bug #216863.


Comment 2 Alexander Larsson 2007-02-15 09:20:36 UTC
What does the file contain?

Comment 3 Alexander Larsson 2007-02-15 15:47:30 UTC
Could be this problem:
https://bugzilla.novell.com/show_bug.cgi?id=244490

Comment 4 Michel Alexandre Salim 2007-02-16 05:07:16 UTC
It might be that. I have several ISOs in the external drive that would appear to
be under $HOME due to symlinking .. but nothing that's > 10 GB in size,
certainly (on my other laptop Beagle consumed 20 GB and then ran out of space)

I'm afraid I did not get to see what the file contained. Upstream seems to have
acknowledged the bug? (Beagle does not have a size limit when unpacking archives??)

Comment 5 Alexander Larsson 2007-02-16 09:29:00 UTC
Joe (assigned to the novell bug) is the upstream maintainer, so he's aware of if.

Comment 6 Matthias Clasen 2007-02-23 04:46:59 UTC
I've built 0.2.16.2 in rawhide, which fixes the novell bug cited above.
Please reopen if this issue is still there.

Comment 7 Tom London 2007-03-03 18:27:44 UTC
I'm still seeing lots of leftover /tmp/tmp*.tmp files each time beagle runs
(from cron?).

I manually remove them each time.

Running beagle-0.2.16.2-1.fc7