Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 228615

Summary: List Tags - Alphabar not working
Product: Red Hat Network Reporter: Partha Aji <paji>
Component: RHN/Web SiteAssignee: Partha Aji <paji>
Status: CLOSED CURRENTRELEASE QA Contact: Preethi Thomas <pthomas>
Severity: medium Docs Contact:
Priority: medium    
Version: rhn500CC: duffy, rhn-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: https://rhn.webtest.redhat.com/rhn/systems/Overview.do
Whiteboard:
Fixed In Version: rhn500h Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-13 17:08:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Partha Aji 2007-02-13 23:24:25 UTC
Description of problem:
The alphabar on pages with list views does not handle the combination of
pagination + alpha selections correctly..

Version-Release number of selected component (if applicable): RHN 500
Hosted + Sat

How reproducible: always


Steps to Reproduce:
1. Register a bunch of systems to a user in hosted.
2. Login to RHN and click on 'Systems' tab
3. A bunch of systems are listed...
4. Click on M from the alpha bar (assuming one of the system names start with a
'M'.. If there is no 'M' choose any other letter & make sure the selection of
the letter leads to a page with a system that starts with the selected letter )
5. Click on |< .. This should move you back to the first page...
6. Click on 'M' or whatever letter you chose in step 4
  
Actual results:
Notice that the loaded page does not go to the page containing systems starting
with 'M' . Instead it remains in the first page (no movement)..

Expected results:
The loaded page should go to the page containing systems starting with 'M' . 

Additional info:
Test other problems in this area.. For example select an alphabet and try  < or
> & see if that looks ok.. Folks have been complaining about this in IE, but it
turns out to be an issue in ff too...

Comment 1 Partha Aji 2007-02-13 23:31:12 UTC
This has now been resolved  in revisions 110831 & 110832

Comment 2 Partha Aji 2007-02-18 06:39:58 UTC
*** Bug 209675 has been marked as a duplicate of this bug. ***

Comment 3 Partha Aji 2007-02-20 23:38:04 UTC
Moving to ON_QA

Comment 4 Preethi Thomas 2007-02-21 19:28:33 UTC
verified on 2/21

Comment 5 Preethi Thomas 2007-03-08 16:16:49 UTC
verified in stage.

Comment 6 Brandon Perkins 2007-03-13 13:59:15 UTC
Closed in rhn500h Release.

Comment 7 Brandon Perkins 2007-03-13 17:08:25 UTC
Closed in rhn500h release.