Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 228372

Summary: multi-lib conflicts
Product: [Fedora] Fedora Reporter: Michael Schwendt <bugs.michael>
Component: libburnAssignee: Denis Leroy <denis>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: denis
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-08 13:31:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 213321    

Description Michael Schwendt 2007-02-12 20:13:43 UTC
libburn - 0.2.6.3-1.fc7.x86_64
  Conflicts: 32
  File conflict in:
     /usr/share/doc/libburn-0.2.6.3/html/comments-source.html
     /usr/share/doc/libburn-0.2.6.3/html/globals_enum.html
     /usr/share/doc/libburn-0.2.6.3/html/libburn_8h__dep__incl.png
     /usr/share/doc/libburn-0.2.6.3/html/libburner_8c-source.html
     /usr/share/doc/libburn-0.2.6.3/html/globals_func.html
     /usr/share/doc/libburn-0.2.6.3/html/globals.html
     /usr/share/doc/libburn-0.2.6.3/html/functions.html
     /usr/share/doc/libburn-0.2.6.3/html/structburn__source__coll__graph.png
     /usr/share/doc/libburn-0.2.6.3/html/functions_vars.html
     /usr/share/doc/libburn-0.2.6.3/html/libburn_8h.html
     /usr/share/doc/libburn-0.2.6.3/html/comments.html
     /usr/share/doc/libburn-0.2.6.3/html/globals_eval.html
     /usr/share/doc/libburn-0.2.6.3/html/libburner_8c__incl.md5
     /usr/share/doc/libburn-0.2.6.3/html/libburner_8c.html
     /usr/share/doc/libburn-0.2.6.3/html/structburn__progress.html
     /usr/share/doc/libburn-0.2.6.3/html/index.html
     /usr/share/doc/libburn-0.2.6.3/html/structburn__toc__entry.html
     /usr/share/doc/libburn-0.2.6.3/html/globals_type.html
     /usr/share/doc/libburn-0.2.6.3/html/files.html
     /usr/share/doc/libburn-0.2.6.3/html/libburn_8h__incl.png
     /usr/share/doc/libburn-0.2.6.3/html/graph_legend.png
     /usr/share/doc/libburn-0.2.6.3/html/annotated.html
     /usr/share/doc/libburn-0.2.6.3/html/libburn_8h__incl.md5
     /usr/share/doc/libburn-0.2.6.3/html/globals_defs.html
     /usr/share/doc/libburn-0.2.6.3/html/libburn_8h-source.html
     /usr/share/doc/libburn-0.2.6.3/html/structburn__source.html
     /usr/share/doc/libburn-0.2.6.3/html/libburner_8c__incl.png
     /usr/share/doc/libburn-0.2.6.3/html/graph_legend.html
     /usr/share/doc/libburn-0.2.6.3/html/libburn_8h__dep__incl.md5
     /usr/share/doc/libburn-0.2.6.3/html/globals_vars.html
     /usr/share/doc/libburn-0.2.6.3/html/structburn__source__coll__graph.md5
     /usr/share/doc/libburn-0.2.6.3/html/structburn__drive__info.html
  Packages with the same files:
     libburn - 0.2.6.3-1.fc7.i386

Comment 1 Jesse Keating 2007-05-22 21:54:11 UTC
Denis, can you take care of this, or have you already?

Comment 2 Denis Leroy 2007-06-06 13:22:25 UTC
Ok, so this is a fairly classic case of multilib conflicts caused by doxygen,
which puts random anchor tags in the generated html files. I suggest 2 solutions:

1) do nothing and close this as won't fix. I don't see what is the real problem
here ? You can safely install both devel packages, RPM won't complain about the
conflicts. They're not even reported by rpm -V, both i386 and x86_64 packages
verify correctly.

2) spin off the documentation into its own noarch package. Its size would be
about 1Mb. Considering that the documentation is not even installed by default
by the upstream makefiles, that seems like a reasonable thing to do.


Comment 3 Michael Schwendt 2007-06-06 14:53:32 UTC
Nobody seems to know whether RPM works around some forms of
conflicts in multilib installs for %doc files. Some Core packagers
(e.g. Matthias Clasen) even prebuild doc files to avoid the conflict.
Perhaps %_docdir is covered by hacks in RPM. %_mandir isn't.


Comment 4 Denis Leroy 2007-06-08 13:31:41 UTC
I can confirm that %doc files seem to be immune to conflicts, at least in this
particular case. Moving the documentation somewhere under %datadir for example,
will cause RPM conflicts, while in this case we have none.

Being naturally lazy, i'm going to close this as WON'T FIX. But if someone has a
strong opinion and want to twist my arm, go ahead and reopen and I'll request
the creation of a new libburn-doc package (seems to be the only way to fix this,
which just seems overkill, though I'm well aware other packages do this already).

I was looking at writing a perl scripts to normalize the HTML anchors used by
doxygen, but there are also conflicts on the png images generated by dot and i
don't know how to prevent those...