Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 228220

Summary: /usr/bin/chkrootkit only runnable from console
Product: [Fedora] Fedora Reporter: Need Real Name <bugzilla>
Component: chkrootkitAssignee: Michael Schwendt <bugs.michael>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-11 21:21:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2007-02-11 21:15:56 UTC
Description of problem:

Why is /usr/bin/chkrootkit linked to /usr/bin/consolehelper?

The result is that you can't run 'chkrootkit' unless you are on the console.
Furthermore, even if you are on the console, 'chkrootkit' won't run within a
'screen' (/usr/bin/screen)

chkrootkit is exactly one of those types of programs that one would like to run
remotely to check whether a server has been hacked.

Even worse, when you run chkrootkit remotely, it just exits quietly giving the
unknowing user no indication of what is going on. Now I know that you can
alternatively just run /usr/lib/chkrootkit-0.47/chkrootkit, but the unsuspecting
user wouldn't know that and would not understand why /usr/bin/chkrootkit is not
working when not on a console.

At a minimum, if not run from the console, it should return a message
instructing the user to either run it from the console or to run
/usr/lib/chkrootkit-0.47/chkrootkit directly.

Comment 1 Need Real Name 2007-02-11 21:21:03 UTC
Sorry... must have hit the 'save changes' button twice causing bug to be
duplicated...

*** This bug has been marked as a duplicate of 228217 ***