Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 228219

Summary: chklastlog points to /var/adm/lastlog
Product: [Fedora] Fedora Reporter: Need Real Name <bugzilla>
Component: chkrootkitAssignee: Michael Schwendt <bugs.michael>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 6Keywords: Reopened
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-11 21:38:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2007-02-11 20:08:14 UTC
Description of problem:

Running '/usr/lib/chkrootkit-0.47/chklastlog' returns the error message:
    unable to open lastlog-file /var/adm/lastlog

The problem is that on Fedora Core systems, the location for lastlog is:
/var/log/lastlog.

Comment 1 Michael Schwendt 2007-02-11 21:06:30 UTC
If you run chkrootkit tools manually, give them proper parameters.


Comment 2 Need Real Name 2007-02-11 21:15:28 UTC
What are the "proper parameters"?(In reply to comment #1)
> If you run chkrootkit tools manually, give them proper parameters.
> 

What are the "proper parameters"?

There is no man page and the README.chklastlog doesn't mention any parameters...


Comment 3 Michael Schwendt 2007-02-11 21:38:21 UTC
chklastlog -l /var/log/lastlog -f /var/log/wtmp

Look, this is a tool used by chkrootkit that is not even in standard
path. So when you run it manually, it can be expected that you become
familiar with it first. chkrootkit runs it, too.

Please report the inaccurate README and the missing manual upstream
at http://www.chkrootkit.org and keep this bug closed. I've patched
chkrootkit for Fedora 7 to default to these two paths. But it is
more important to get such changes into upstream chkrootkit.