Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 228151

Summary: kdm support for XDG_SESSION_COOKIE
Product: [Fedora] Fedora Reporter: Ilya Konstantinov <ilya.konstantinov>
Component: kdebaseAssignee: Ngo Than <than>
Status: CLOSED DUPLICATE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: mattdm, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-01 12:50:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ilya Konstantinov 2007-02-10 17:15:27 UTC
kdm should add the XDG_SESSION_COOKIE environment variable, like gdm does.
Otherwise ConsoleKit doesn't work in kdm-initiated sessions, breaking things
like  mounting through HAL (since HAL nowadays validates mount requests through
ConsoleKit).

Comment 1 Matthew Miller 2007-04-10 16:32:56 UTC
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.

Comment 2 Rex Dieter 2007-04-30 17:34:26 UTC
Related to bug #228111 ?

Comment 3 Ilya Konstantinov 2007-04-30 19:37:33 UTC
This is indeed a prerequisite for ConsoleKit to work. You can make it a
dependency of bug #228111.

Comment 4 Kevin Kofler 2007-05-01 12:50:46 UTC
XDG_SESSION_COOKIE is actually set by my patch in #228111.

+#ifdef WITH_CONSOLE_KIT
+	if (ck_session_cookie != NULL) {
+		env = setEnv ( env, "XDG_SESSION_COOKIE", ck_session_cookie );
+	}
+#endif

(and WITH_CONSOLE_KIT is currently always defined in dm.h, I haven't bothered 
making it conditional).

*** This bug has been marked as a duplicate of 228111 ***