Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 227819

Summary: PERC5/E: Controller replacement results in failure of normal OS boot up
Product: Red Hat Enterprise Linux 4 Reporter: Shyam kumar Iyer <shyam_iyer>
Component: e2fsprogsAssignee: Thomas Woerner <twoerner>
Status: CLOSED DUPLICATE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.4CC: sct, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-08 13:06:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Shyam kumar Iyer 2007-02-08 13:02:09 UTC
Description of problem:
Replacing PERC5/E controller attached to an MD1000 storage box results in fsck 
errors during boot up and root filesystem does not get mounted. By rebooting 
again the issue is not founf. By removing the /etc/blkid.tab file before 
changing the PERC5/E controller results in the /etc/blkid.tab file being 
generated freshly and again the issue doesn't occur again. 
So, the bug is in the blkid tool in the e2fsprogs application which runs fsck 
on the partitions before mounting them.

Version-Release number of selected component (if applicable):
e2fsprogs-1.35-12.4.EL4

How reproducible:
Often.

Steps to Reproduce:
1) Install RHEL4 U4 32bit (kernel version : 2.6.9-42.ELsmp) on RAID5 on 
PERC5iA.
2)Create two or three VD's on PERC5/E from OMSS or the controller BIOS.
3)Shutdown the system and replace the PERC5/E controller with another one with 
same fw level and having no config on it.
4)Switch ON the system and observe the booting process.Booting ends up on the 
screen "Give root password for maintenance".
  
Actual results:
Fsck error occurs resulting in filesystem not being mounted.

Expected results:
System boot should be error free even the first time.

Additional info:
1) Basically the fsck on / fails and filesystem is not mounted. 
2) Manually mounting the filesystem after running fsck makes the problem go 
away.
3) Simply rebooting the system at this time makes the problem go away.
4) Deleting the /etc/blkid.tab before changin the PERC5/E controller makes the 
problem go away.

Comment 1 Shyam kumar Iyer 2007-02-08 13:06:57 UTC
Duplication of BZ227813 caused due to duplicate submittions hence please close 
this one.

*** This bug has been marked as a duplicate of 227813 ***