Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 227754

Summary: db.m4 needs to set the library path when using AC_CHECK_LIB
Product: [Retired] 389 Reporter: Nathan Kinder <nkinder>
Component: Directory ServerAssignee: Nathan Kinder <nkinder>
Status: CLOSED CURRENTRELEASE QA Contact: Viktor Ashirov <vashirov>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0.4CC: nhosoi, rmeggins
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-12-07 16:31:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 427409    
Attachments:
Description Flags
Proposed Fix
none
CVS Commit Message none

Description Nathan Kinder 2007-02-07 22:21:40 UTC
Our db.m4 file checks for the db_create function in libdb-4.2.so.  The problem
is that it doesn't take the path that is passed in via "--with-db" when trying
to locate the library.  This causes configure to either use an incorrect system
libdb , or configure fails on this check since it can't find libdb.

Comment 1 Nathan Kinder 2007-02-07 22:24:49 UTC
Created attachment 147607 [details]
Proposed Fix

This fix simply adds the path to libdb as part of the library search path.  I
also updated some message formatting in a couple of our other m4 files to be
consistent with the rest of our message formatting.

Comment 2 Nathan Kinder 2007-02-07 23:28:17 UTC
Created attachment 147612 [details]
CVS Commit Message

Checked into ldapserver (HEAD).  Thanks to Noriko and Rich for reviews.