Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 227661

Summary: Frequent crashing when opening files
Product: [Fedora] Fedora Reporter: David Nielsen <gnomeuser>
Component: totemAssignee: Bastien Nocera <bnocera>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-08 12:42:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150226    
Attachments:
Description Flags
backtrace of crash none

Description David Nielsen 2007-02-07 13:27:18 UTC
Description of problem:
Totem tends to hang or crash on opening files quite frequently on Development
currently.

Version-Release number of selected component (if applicable):
totem-2.17.90-1.fc7
gstreamer-0.10.11-1.fc7
gstreamer-plugins-good-0.10.5-2.fc7
gstreamer-plugins-base-0.10.11-1.fc7
gstreamer-plugins-ugly-0.10.5-1.lvn7

How reproducible:
Close to 100%

Steps to Reproduce:
1. click media file, select open with Totem
  
Actual results:
Totem will now hang requiring a forceful exit or crash with the attached
backtrace. Repeatedly attempting to open the file will eventually lead to
correct playback.

Expected results:
Correct playback for all supported media types.

Additional info:

Comment 1 David Nielsen 2007-02-07 13:27:18 UTC
Created attachment 147558 [details]
backtrace of crash

Comment 2 Bastien Nocera 2007-02-07 13:53:38 UTC
Looks like the upstream fix:

2007-01-30  Tim-Philipp Müller  <tim at centricular dot net>

        * src/totem-menu.c: (create_lang_actions):
          Don't let hash table take ownership of and free strings that it
          doesn't own (causes crashes in totem_sublang_update() when accessing
          already freed memory or trying to free it again); also fix up hash
          table usage so that it really detects equal language strings.
          (Closes: #402512)

I'll need to make a new release...

Comment 3 David Nielsen 2007-02-07 17:56:11 UTC
I patched up totem and it's like magic, things work again.. Tim is a regular
hero as always.

Comment 4 Bastien Nocera 2007-02-08 12:42:31 UTC
Fixed in totem-2.17.91-1.fc7