Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 227643

Summary: username and password lost in DeviceURI after apply changes
Product: [Fedora] Fedora Reporter: C. N. Tsang <tsangcn1>
Component: system-config-printerAssignee: Tim Waugh <twaugh>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 0.7.52-1.fc6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-15 09:55:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 207681    

Description C. N. Tsang 2007-02-07 10:48:12 UTC
Description of problem:
-----------------------
for printers connected through samba, username and password in Device URI is
lost after apply changes using system-config-printer

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
system-config-printer-0.7.49-1.fc6
system-config-printer-libs-0.7.49-1.fc6

How reproducible:
-----------------
It can always be reproduced.

Steps to Reproduce:
1. start system-config-printer
2. select a printer, say HPLaserJ, the Device URI in the right hand side is
protected field showing something like smb://…/myserver/HPLaserJ
(The DeviceURI in file /etc/cups/printers.conf for this printer is showing
something like smb://myuser:mypass@/myserver/HPLaserJ)
3. Change any other field, say click on the Enabled checkbox to change from on
to off.
4. Click the Apply button.
5. Look at the file /etc/cups/printers.conf, the line for DeviceURI for this
printer now showing something like smb://…/myserver/HPLaserJ
6. The Device URI field in the right hand side of system-config-printer becomes
a input capable field
7. The printer is not functioning because of authentication failure.
  
Actual results:
---------------
After applying any changes in system-config-printer, the "username:password" in
DeviceURI in /etc/cups/printers.conf is changed to "…"


Expected results:
-----------------
After applying any changes in system-config-printer, it should display the
Device URI as something like smb://…/myserver/HPLaserJ but it should not change
the DeviceURI in /etc/cups/printers.conf to something like
smb://…/myserver/HPLaserJ (it should keep it as
smb://myuser:mypass@/myserver/HPLaserJ)

Additional info:

Comment 1 Tim Waugh 2007-02-07 13:26:36 UTC
Fixed in CVS.

Comment 2 Tim Waugh 2007-02-08 10:23:27 UTC
Please try 0.7.50-1.fc6 from updates-testing:

yum --enablerepo=updates-testing update 'system-config-printer*'


Comment 3 C. N. Tsang 2007-02-09 03:52:49 UTC
Yes, the 0.7.50-1.fc6 from updates-testing has fixed the problem.

Comment 4 Tim Waugh 2007-02-09 10:51:50 UTC
Great, thanks for testing.

Comment 5 Fedora Update System 2007-02-14 19:59:56 UTC
Fixed in update: system-config-printer-0.7.52-1.fc6