Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 227539

Summary: Missing package beryl-plugins-unsupported
Product: [Fedora] Fedora Reporter: Jared Brown <jaredbrown>
Component: beryl-pluginsAssignee: Jarod Wilson <jarod>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 6Keywords: Reopened
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-23 21:58:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jared Brown 2007-02-06 19:31:41 UTC
Description of problem:

As of Release: 0.1.9999.1 the Beryl project has split the plugins and now
maintains unsupported plugins in a separate archive. These plugins are missing
in Extras. There should be a package for beryl-plugins-unsupported.

Version-Release number of selected component (if applicable): 0.1.9999.1

Comment 1 Jarod Wilson 2007-02-06 19:45:19 UTC
Based on the name of the package and its README (included below), I'm somewhat
inclined to say no thank you to packaging these bits up... Is there really a
compelling reason to do this? I suppose if they're in their own package that
people have to manually install (i.e., not sucked in by beryl-gnome or
beryl-kde), it wouldn't hurt too much...

----8<----
Beryl extra plugins:

this module contains plugins that are either:
* unstable
* only modestly maintained
* or completely unmaintained

We don't want to drop them, and will do baseline maintenance to make sure
they compile (should they be unmaintained).

We hope to get them maintained or stabilized, and pulled back into -plugins.

THESE ARE NOT MEANT FOR PRODUCTION SYSTEMS!

THESE ARE UNSUPPORTED OFFICIALLY!

Use at your own risk.
----8<----

Comment 2 Jarod Wilson 2007-02-22 21:58:32 UTC
Due to lack of a compelling reason to package the -unsupported beryl plugins,
closing WONTFIX.

Comment 3 Jared Brown 2007-02-23 00:44:20 UTC
I suggest that this bug be revisited and have therefore reopened it. I agree
that the package shouldn't be required by any other packages due to its nature.
This package would provide additional features to a user. It is preferred that
it is provided via a repository. This is attractive to users such as myself who
were happily using certain plugins that until recently were part of the standard
plugin set. The package would be clearly named as unsupported so users would be
informed of what they are installing. In my experience the plugins provided were
stable and provided attractive features. Part of the fun of Beryl is to be able
to play around with these new features and plugins. By including this package
users will be able to try these plugins out and possibly decide to take over
their maintenance.

Comment 4 Jarod Wilson 2007-02-23 21:58:04 UTC
Okay, fine, but you get to pick up the pieces. :)

New build including unsupported forthcoming...

Comment 5 Jared Brown 2007-02-23 22:10:38 UTC
Great! :)