Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 227278

Summary: reiserfstune not found during install
Product: [Fedora] Fedora Reporter: Will Woods <wwoods>
Component: anacondaAssignee: Chris Lumens <clumens>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: andy.grimm
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-23 16:01:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150226    
Attachments:
Description Flags
full anaconda traceback none

Description Will Woods 2007-02-04 17:30:43 UTC
While installing onto a system using a pre-existing reiserfs /home, anaconda
traces back because it can't find reiserfstune.

Traceback follows - full dump is attached.

Traceback (most recent call first):
  File "/usr/lib/anaconda/iutil.py", line 51, in execWithRedirect
    raise RuntimeError, "Error running " + command + ": " + msg
  File "/usr/lib/anaconda/fsset.py", line 434, in labelDevice
    stderr = "/dev/tty5", searchPath = 1)
  File "/usr/lib/anaconda/fsset.py", line 1571, in labelEntry
    entry.fsystem.labelDevice(entry, chroot)
  File "/usr/lib/anaconda/fsset.py", line 1688, in makeFilesystems
    self.labelEntry(entry, chroot)
  File "/usr/lib/anaconda/packages.py", line 144, in turnOnFilesystems
    anaconda.id.fsset.makeFilesystems (anaconda.rootPath)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 973, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 247, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1000, in handleRenderCallback
    self.currentWindow.renderCallback()
RuntimeError: Error running reiserfstune: No such file or directory

Comment 1 Will Woods 2007-02-04 17:30:44 UTC
Created attachment 147309 [details]
full anaconda traceback

Comment 2 Jeremy Katz 2007-02-05 21:21:22 UTC
We should make it so that we handle the tools for various filesystems not being
there better

Comment 3 David Cantrell 2007-02-06 16:08:35 UTC
reiserfstune should be there.  scripts/upd-instroot has reiserfs-utils in the
pile of packages to use to build the stage2 image.

Still, I agree with Jeremy, execWithRedirect (among others) could gracefully
handle a tool missing.

Comment 4 Chris Lumens 2007-02-21 18:38:03 UTC
What are the exact install parameters here?  reiserfs on a /home partition, no
existing other installs or partitions?

Comment 5 Will Woods 2007-03-22 21:03:25 UTC
I believe there was an existing install on the disk that was being replaced with
F7t1, where /home was reiserfs and the other partitions were (probably) ext3 -
IIRC the user was attempting to install (not upgrade) but also wanted to
preserve /home.

Comment 6 Chris Lumens 2007-03-23 15:16:51 UTC
I'm unable to reproduce this today.  Perhaps there was some transient tree
weirdness that caused reiserfstune to not be in the image?

Comment 7 Will Woods 2007-03-23 15:25:46 UTC
Possibly. Does reiserfstune live in initrd or stage2? We should compare the
current rawhide one to the F7t1 one and see if the location (or presence) of the
file has changed.

Comment 8 Chris Lumens 2007-03-23 16:01:48 UTC
Looks like it was left out of the minstg2.img on Test 1, but it's in the images
now.  Closing out.

Comment 9 Jesse Keating 2007-03-23 19:46:17 UTC
Just to clarify, the reiserfs tools didn't make the manifest for Test1 (and
possibly test2).  Twas a pungi bug.