Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 227025

Summary: do not restart httpd in scriptlets
Product: [Fedora] Fedora Reporter: Joe Orton <jorton>
Component: phpMyAdminAssignee: Mike McGrath <mmcgrath>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: redhat-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.11.3-1.fc7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-12-10 20:44:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joe Orton 2007-02-02 17:20:29 UTC
Description of problem:
Please don't restart httpd in scriptlets.  This must be left to root to do as
and when they decide it is necessary.

e.g. if httpd.conf is in a bad state the condrestart unnecessarily kills httpd.
 If e.g. this is a production server the condrestart kills active requests.

Version-Release number of selected component (if applicable):
phpMyAdmin-2.9.2-1.fc6

Comment 1 Mike McGrath 2007-02-02 19:50:30 UTC
I could have sworn that condrestart was a policy of ours.  Let me do some
research and make sure its not.  If its not I'll turn it off, if it is perhaps
we need to change it.

Comment 3 Robert Scheck 2007-12-09 13:32:49 UTC
I had a look to the other httpd specific packages and none seems to do such a 
conditional restart. Anyway I'm personally really pissed of each time, I apply 
a phpMyAdmin update and httpd goes down for the restart (because it takes a 
couple of time at our servers).

I would remove that condrestart with the next update of the package.

Comment 4 Joe Orton 2007-12-10 10:22:50 UTC
Also e.g. if you get ten different httpd modules updated in a single transaction
you get ten separate restarts.   It's just nuts - don't do it :)

Comment 5 Fedora Update System 2007-12-10 20:44:45 UTC
phpMyAdmin-2.11.3-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2007-12-10 20:47:03 UTC
phpMyAdmin-2.11.3-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.