Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 226923

Summary: Upgrade fails to mount existing partition
Product: [Fedora] Fedora Reporter: Adam Huffman <bloch>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED CANTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-26 19:11:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Adam Huffman 2007-02-02 01:11:16 UTC
Description of problem:
I tried to test upgrades using an F7 test1 DVD.  The installer aborted the
session because it couldn't mount one of the partitions listed in the current
(FC6) fstab - /mnt/hda3

Version-Release number of selected component (if applicable):
F7 test1 version

How reproducible:


Steps to Reproduce:
1. Boot to DVD
2. Select upgrade
3.
  
Actual results:
Installer aborts

Expected results:
Installation proceeds normally

Additional info:
I had to insert manually the pata_amd module - this has been noted in other bugs

Comment 1 Adam Huffman 2007-02-05 00:42:45 UTC
Even after I altered /etc/fstab to mount by partition label, the installer
aborted in the same way when it couldn't mount the swap partition.

Comment 2 Jeremy Katz 2007-02-05 21:14:42 UTC
Is your swap partition referenced by label?

Comment 3 Adam Huffman 2007-02-06 13:46:52 UTC
It's not.  Can one label a partition for swap?

Comment 4 Jeremy Katz 2007-02-26 19:11:48 UTC
Yes.  And we've been doing so on installs since FC3 :)