Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2268

Summary: samba-1.9.18p10-5.i386.rpm segfaults rpm
Product: [Retired] Red Hat Linux Reporter: jherzog
Component: sambaAssignee: Trond Eivind Glomsrxd <teg>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-04-26 21:45:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jherzog 1999-04-19 14:54:47 UTC
I was using samba-1.9.18p5-1.i386.rpm and running along
smoothly when I decided to update to
samba-1.9.18p10-5.i386.rpm. After downloading the rpm from
your site and upgrading (via "rpm -Uvh"), rpm segfaulted
after the last hash mark was printed. Now rpm thinks both
packages are installed:
---
[root@threshold RPMS]# rpm -qa | grep samba
samba-1.9.18p10-5
samba-1.9.18p5-1
---
and I can't uninstall either:
---
[root@threshold RPMS]# rpm -e samba-1.9.18p10-5
Segmentation fault
[root@threshold RPMS]# rpm -e samba-1.9.18p5-1
Segmentation fault
[root@threshold RPMS]# rpm -e --test samba-1.9.18p5-1
Segmentation fault
[root@threshold RPMS]# rpm -e --test samba-1.9.18p10-5
Segmentation fault
---
And this is all after I rebuilt the database.

I'm not a registered user, so I don't expect much help on
this, but I thought you'd like to know.

Thanks.

Comment 1 jherzog 1999-04-19 15:00:59 UTC
Sorry I didn't include this before:
---
[root@threshold RPMS]# rpm -e -vv samba-1.9.18p10-5
D: counting packages to uninstall
D: opening database in //var/lib/rpm/
D: found 1 packages to uninstall
D: uninstalling record number 3593560
Segmentation fault
[root@threshold RPMS]# rpm -e -vv samba-1.9.18p5-1
D: counting packages to uninstall
D: opening database in //var/lib/rpm/
D: found 1 packages to uninstall
D: uninstalling record number 4693592
Segmentation fault

Comment 2 Bill Nottingham 1999-04-19 15:08:59 UTC
do rpm -e --notriggers samba

Comment 3 jherzog 1999-04-19 15:13:59 UTC
Okay:
---
[root@threshold RPMS]# rpm -e --notriggers samba-1.9.18p10-5
cannot remove /var/log/samba - directory not empty
cannot remove /etc/codepages - directory not empty
[root@threshold RPMS]# rpm -qa | grep samba
samba-1.9.18p5-1
---
Ah, so it was a script that was segfaulting. Interesting.

Comment 4 jherzog 1999-04-19 23:04:59 UTC
Well, I was able to uninstall samba-1.9.18p5-1.i386.rpm using "rpm -e
--notriggers" in combination with "rpm -q --scripts" and running the
scripts by hand. I could then install samba-1.9.18p10-5.i386.rpm the
same way. I don't know where the segfault came from, but it was
probably actually some command in the scripts that had the error. Why
doesn't rpm handle things like this gracefully? It would seem a
trivial thing for rpm to tell me which part of the script had a
problem... but this is a issue with rpm, not redhat per se.

Anyway, thanks for the help.

Comment 5 Bill Nottingham 1999-04-26 21:45:59 UTC
It didn't handle it because of a bug in RPM, which I
believe was fixed in a later version.