Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 226667

Summary: Merge Review: yum-metadata-parser
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Jeremy Katz <katzj>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bkearney, katzj, pertusus, tla
Target Milestone: ---Flags: tla: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-07-11 11:49:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nobody's working on this, feel free to take it 2007-01-31 21:36:46 UTC
Fedora Merge Review: yum-metadata-parser

http://cvs.fedora.redhat.com/viewcvs/devel/yum-metadata-parser/
Initial Owner: katzj@redhat.com

Comment 1 Tim Lauridsen 2007-02-13 14:49:29 UTC
Starting review

Comment 2 Tim Lauridsen 2007-02-13 14:50:30 UTC
OK - spec filename is %{name}.spec
OK - source match upstream md5sum
     8cc782b0a6fbca137b133fe6294ce000  yum-metadata-parser-1.0.3.tar.gz
OK - Package naming 
OK - Spec in American English and legible
OK - License : GPL
OK - BuildRequires correct
OK - Package has %defattr and permissions on files is good.
OK - Package has a correct %clean section.
   - License file (COPYING) is included in %doc
OK - Package is code or permissible content.
OK - Packages %doc files don't affect runtime.
OK - Package owns all the directories it creates.
OK - Buildroot is %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
OK - Package is compiling and building on i386.

Comments:
 * No Licens file in upstream source.

rpmlint:
[tim@naboo devel]$ rpmlint yum-metadata-parser-1.0.3-1.src.rpm 
E: yum-metadata-parser no-cleaning-of-buildroot %install

[tim@naboo i386]$ rpmlint yum-metadata-parser-1.0.3-1.i386.rpm 
silent

Summery:
 * rm -rf $RPM_BUILD_ROOT should be added to %install


Comment 3 James Bowes 2007-02-13 15:52:24 UTC
I added removing the buildroot the %install, in y-m-p-1.0.3-2

Comment 4 Tim Lauridsen 2007-02-14 08:13:58 UTC
The updated spec file looks fine, so i will approve it.

APPROVED

Comment 5 Patrice Dumas 2007-02-14 09:32:53 UTC
Issue:

* The conflict seems wrong, yum with high enough versions already 
  requires yum-metadata-parser. Besides is there a real Conflict?

Suggestion:

* use %defattr(-,root,root,-) instead of %defattr(-,root,root)

Comment 6 Tim Lauridsen 2007-03-09 10:08:30 UTC
(In reply to comment #5)
> Issue:
> 
> * The conflict seems wrong, yum with high enough versions already 
>   requires yum-metadata-parser. Besides is there a real Conflict?
> 
You are right, i don't see reason for the conflict, it would not hurt a older 
version for yum to install yum-metadata-parser, it would just not be used.

James, any comments ????



Comment 7 James Bowes 2007-07-11 01:23:08 UTC
As of now (yum-3.2, ymp-1.1), the conflict is required because of the dbformat
change.

The defattr suggestion sounds sane; I'll put that in devel (presuming the acl
lets me).

So, is it fair to consider this one closed?

Comment 8 Tim Lauridsen 2007-07-11 11:40:25 UTC
Fine with me

Comment 9 Patrice Dumas 2007-07-12 06:02:24 UTC
(In reply to comment #7)
> As of now (yum-3.2, ymp-1.1), the conflict is required because of the dbformat
> change.

I may be wrong, but it seems to me that the conflict isn't
needed since yum already requires yum-metadata-parser, the requires
in yum should be versioned such that yum-3.2 cannot be installed 
together with  ymp < 1.1. 

If you don't know that guideline already:
http://fedoraproject.org/wiki/Packaging/Conflicts


Otherwise rpmlint says:
W: yum-metadata-parser no-version-in-last-changelog


Comment 10 Jeremy Katz 2007-07-12 13:27:18 UTC
(In reply to comment #9)
> (In reply to comment #7)
> > As of now (yum-3.2, ymp-1.1), the conflict is required because of the dbformat
> > change.
> 
> I may be wrong, but it seems to me that the conflict isn't
> needed since yum already requires yum-metadata-parser, the requires
> in yum should be versioned such that yum-3.2 cannot be installed 
> together with  ymp < 1.1. 

That's not the problem, though -- the problem is if you have older yum installed
and then install newer yum-metadata-parser.  This is exactly the case that
Conflicts are supposed to be used for

> Otherwise rpmlint says:
> W: yum-metadata-parser no-version-in-last-changelog

That's because the last change is committed in CVS but release wasn't bumped and
a build wasn't done because it wasn't worth pushing on its own.



Comment 11 Patrice Dumas 2007-07-12 15:47:44 UTC
(In reply to comment #10)

> That's not the problem, though -- the problem is if you have older yum installed
> and then install newer yum-metadata-parser.  This is exactly the case that
> Conflicts are supposed to be used for

Ok. 

Maybe yum-metadata-parser could Requires yum instead? It seems to me 
that yum-metadata-parser is useless without yum? Is it because yum 
already requires it?

> That's because the last change is committed in CVS but release wasn't bumped and
> a build wasn't done because it wasn't worth pushing on its own.

Ah, I see, sorry, I didn't thought about that (although the issue
seemed a bit strange given who the packagers are ;-).