Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 226460

Summary: freenx: should be noarch
Product: [Fedora] Fedora Reporter: Ville Skyttä <ville.skytta>
Component: freenxAssignee: Axel Thimm <axel.thimm>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideKeywords: Patch
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-19 11:47:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Make package noarch none

Description Ville Skyttä 2007-01-31 21:05:50 UTC
Caught by the debuginfo sanity checking script [1], it looks like freenx should
be noarch.  You can use both "BuildArch: noarch" and "ExcludeArch: x86_64" and
the FE buildsys/release scripts will build it as noarch but prevent it from
being pushed to the x86_64 repository.

[1] http://www.redhat.com/archives/fedora-maintainers/2007-January/msg00339.html

Comment 1 Ville Skyttä 2007-01-31 21:05:50 UTC
Created attachment 147050 [details]
Make package noarch

Comment 2 Axel Thimm 2007-05-19 11:47:31 UTC
Hi,

freenx needs to remain arch specific because of the libexec contents that have
different paths to /usr/lib and /usr/lib64.

Comment 3 Ville Skyttä 2007-05-19 14:08:44 UTC
Looks like nowadays freenx contains also arch dependent nxserver-helper binary.