Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 226442

Summary: Merge Review: swig
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Miroslav Lichvar <mlichvar>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: atkac, mlichvar, redhat-bugzilla
Target Milestone: ---Flags: mlichvar: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-12-07 12:02:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nobody's working on this, feel free to take it 2007-01-31 21:03:09 UTC
Fedora Merge Review: swig

http://cvs.fedora.redhat.com/viewcvs/devel/swig/
Initial Owner: atkac@redhat.com

Comment 1 Miroslav Lichvar 2009-12-03 15:16:43 UTC
OK source files match upstream:
2df766c9e03e02811b1ab4bba1c7b9cc  swig-1.3.40.tar.gz

OK package meets naming and versioning guidelines.
NO specfile is properly named, is cleanly written and uses macros consistently.
- both $RPM_BUILD_ROOT and %{_builddir} are used
OK dist tag is present.
OK build root is correct.
NO license field matches the actual license.
- the actual license seems to be BSD and MIT
OK license is open source-compatible.
NO License text included in package
- the text is included in -doc subpackage, but I think should be in the main package with all other files except Doc and Examples directory.
OK latest version is being packaged.
OK BuildRequires are proper.
OK compiler flags are appropriate.
OK %clean is present.
OK package builds in mock.
OK debuginfo package looks complete.
NO rpmlint is silent.
swig.x86_64: W: summary-ended-with-dot Connects C/C++/Objective C to some high-level programming languages.
swig.x86_64: W: devel-file-in-non-devel-package /usr/share/swig/1.3.40/ocaml/swigp4.ml
swig.x86_64: W: devel-file-in-non-devel-package /usr/share/swig/1.3.40/perl5/noembed.h
swig.x86_64: W: devel-file-in-non-devel-package /usr/share/swig/1.3.40/ocaml/swig.ml
swig.x86_64: W: devel-file-in-non-devel-package /usr/share/swig/1.3.40/ocaml/swig.mli
- the summary should be fixed. The rest is ok as swig is a development package.

OK final provides and requires look sane.
NO %check is present and all tests pass.
- the package contains a testsuite, but it seems to fail, so it's disabled. It would be nice to get it working, but I don't think this is a blocker. Adding a %check with #make check and a comment why it's currently disabled should be fine.
OK no shared libraries are added to the regular linker search paths
OK owns the directories it creates.
OK doesn't own any directories it shouldn't.
OK no duplicates in %files.
OK file permissions are appropriate.
NO scriptlets are sane
- the ldconfig calls are unnecessary, there are no libraries installed.
OK code, not content.
OK documentation is large, -docs subpackage used.
OK %docs are not necessary for the proper functioning of the package.
OK no headers.
- there are actually some headers installed but they are used only by swig.
OK no pkgconfig files.
OK no libtool .la droppings.
OK not a GUI app.

Comment 2 Adam Tkac 2009-12-07 11:46:46 UTC
(In reply to comment #1)
> NO %check is present and all tests pass.
> - the package contains a testsuite, but it seems to fail, so it's disabled. It
> would be nice to get it working, but I don't think this is a blocker. Adding a
> %check with #make check and a comment why it's currently disabled should be
> fine.

Testcase is currently broken, I've added comment about it.

All issues should be fixed in the latest build, swig-1.3.40-2.fc13.

Comment 3 Miroslav Lichvar 2009-12-07 12:02:57 UTC
Approved.

Comment 4 Adam Tkac 2009-12-07 13:05:17 UTC
Thanks for the review.