Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 226331

Summary: Merge Review: pydict
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Susi Lehtola <susi.lehtola>
Status: CLOSED NOTABUG QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: pnemade, smohan, susi.lehtola
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-08 09:41:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nobody's working on this, feel free to take it 2007-01-31 20:45:10 UTC
Fedora Merge Review: pydict

http://cvs.fedora.redhat.com/viewcvs/devel/pydict/
Initial Owner: majain@redhat.com

Comment 1 Susi Lehtola 2009-05-06 14:23:53 UTC
- Buildroot is obsolete. Use
 %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
instead.


rpmlint output is clean.


MUST: The spec file for the package is legible and macros are used consistently. OK
MUST: The package must be named according to the Package Naming Guidelines. OK
MUST: The spec file name must match the base package %{name}. OK
MUST: The package must be licensed with a Fedora approved license and meet the  Licensing Guidelines. OK

MUST: The License field in the package spec file must match the actual license. NEEDSFIX
- There is no mention of a license in the package!

MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. NEEDSFIX
- Source url is missing!

MUST: The package MUST successfully compile and build into binary rpms. OK
MUST: The spec file MUST handle locales properly. OK

MUST: Optflags are used and time stamps preserved. NEEDSFIX
- Time stamps are lost in install and in character set conversion.

MUST: A package must own all directories that it creates or require the package that owns the directory. OK
MUST: Files only listed once in %files listings. OK
MUST: Debuginfo package is complete. N/A
MUST: Permissions on files must be set properly. OK
MUST: Clean section exists. OK
MUST: Large documentation files must go in a -doc subpackage. N/A
MUST: All relevant items are included in %doc. Items in %doc do not affect runtime of application. OK

MUST: Desktop files are installed properly. ~OK
- Vendor tag is incorrect. In fact there shouldn't be any, but this can't be changed due to compatibility reasons.

MUST: No file conflicts with other packages and no general names. OK
MUST: Buildroot cleaned before install. OK
SHOULD: %{?dist} tag is used in release. OK
SHOULD: If the package does not include license text(s) as separate files from upstream, the packager should query upstream to include it. OK
SHOULD: The package builds in mock. OK

Comment 2 Susi Lehtola 2009-06-14 16:13:06 UTC
ping rbhalera

Comment 3 Susi Lehtola 2009-08-05 11:25:18 UTC
ping again?

Comment 5 Susi Lehtola 2010-01-01 22:48:13 UTC
cc pnemade

ping again

Comment 6 Parag Nemade 2010-01-02 07:02:23 UTC
Thanks, I thought previous owner already fixed this package. I got it in June 2009 but was not knowing that time about this review. Will work on this on Monday.

Comment 7 Parag Nemade 2010-01-05 06:41:13 UTC
please wait till Friday as I am checking if this package can be retired from Fedora as stardict looks providing same functionality and pydict code is having old function calls which are deprecated now.

Comment 8 Parag Nemade 2010-02-08 09:41:35 UTC
Officially Retired this Package now.