Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 226267 (perl-LDAP)

Summary: Merge Review: perl-LDAP
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Robin Norwood <robin.norwood>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: cweyl, ppisar, robin.norwood
Target Milestone: ---Flags: jochen: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-21 20:42:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nobody's working on this, feel free to take it 2007-01-31 20:36:31 UTC
Fedora Merge Review: perl-LDAP

http://cvs.fedora.redhat.com/viewcvs/devel/perl-LDAP/
Initial Owner: rnorwood@redhat.com

Comment 1 Jochen Schmitt 2007-04-03 16:26:05 UTC
Good:
+ Tar ball matches with upstream.
+ Rpmlint ok for source package.
+ Local build works fine.

Bad:
- Rpmlint complaint binary rpm:
rpmlint perl-LDAP-0.34-1.noarch.rpm
E: perl-LDAP useless-explicit-provides perl(Net::LDAP::Filter)






Comment 2 Robin Norwood 2007-04-05 17:03:54 UTC
Ok - filtering out the provides for perl(Net::LDAP::Filter) in the usual way.

(http://fedoraproject.org/wiki/Packaging/Perl)

Comment 3 Robin Norwood 2007-04-10 14:17:18 UTC
oops - turns out when I actually looked at it that the problem with the provides
was that there is a versioned "Provides: perl(Net::LDAP::Filter) = 15", and and
unversioned "Provides: perl(Net::LDAP::Filter)".  So, the filter had to be
changed to only filter out the 'unversioned' one.

Comment 4 Jochen Schmitt 2007-06-21 18:13:57 UTC
Ping morwood@redhat.com

Comment 5 Jochen Schmitt 2007-06-21 18:23:55 UTC
Good:
+ Rpmlint quite on binary package.
+ Filelist seems ok.
+ Local install and uninstall works fine.
+ Mock build works fine.
+ License seems ok.

Bad.
- Package should not used Epoch Tag. (No blocker, becouse changing it may breaks
EVR path)

*** APPROVED ***



Comment 6 Robin Norwood 2007-06-21 19:23:23 UTC
Thanks for the review.



Comment 7 Jochen Schmitt 2007-06-21 20:42:03 UTC
I think, is ok, when I close this bug.

Comment 8 Petr Pisar 2012-11-26 09:30:52 UTC
Package Change Request
======================
Package Name: perl-LDAP
Branches: f16 f17 f18
Owners: 
InitialCC: perl-sig

Please add pseudo-user `perl-sig' with watch* permission only to all Fedora branches.

Comment 9 Gwyn Ciesla 2012-11-26 13:03:58 UTC
Done.