Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 226094

Summary: Merge Review: libXxf86dga
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Thomas Spura <tomspur>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: ajax, peter.hutterer, sandmann, tomspur
Target Milestone: ---Flags: tomspur: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-19 09:51:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nobody's working on this, feel free to take it 2007-01-31 19:33:36 UTC
Fedora Merge Review: libXxf86dga

http://cvs.fedora.redhat.com/viewcvs/devel/libXxf86dga/
Initial Owner: sandmann@redhat.com

Comment 1 Thomas Spura 2010-07-18 23:30:51 UTC
Review:
(CC'ing the people, who modified this recently.)

Good:
- name ok
- BR ok (pkgconfig is unneeded, but that doesn't matter here)
- %prep ok
- rpmlint:
libXxf86dga.src: W: invalid-url Source0: ftp://ftp.x.org/pub/individual/lib/libXxf86dga-1.1.1.tar.bz2 <urlopen error ftp error: timed out>
libXxf86dga.x86_64: W: spelling-error Summary(en_US) runtime -> run time, run-time, runtish
- %files ok
- license ok
- latest version packaged
- libs correctly packaged
- no locale files
- no *.la


Needswork:
- https://fedoraproject.org/wiki/Packaging/Guidelines#Parallel_make
- please use INSTALL="install -p", when installing
- libXxf86dga.x86_64: W: name-repeated-in-summary C libXxf86dga
  A slightly bigger description wouldn't hurt.
- libXxf86dga.src:51: W: macro-in-comment %doc -> should be %%doc
- %doc: There is also a README

___________________________________________________________________________


Not much to do, but not approving this now, because this is a merge review and not a normal package review...

Comment 2 Peter Hutterer 2010-07-19 04:46:28 UTC
(In reply to comment #1)
> Needswork:
> - https://fedoraproject.org/wiki/Packaging/Guidelines#Parallel_make
done
> - please use INSTALL="install -p", when installing
done

> - libXxf86dga.x86_64: W: name-repeated-in-summary C libXxf86dga
>   A slightly bigger description wouldn't hurt.

no, people may be tempted to use it then ;)

> - libXxf86dga.src:51: W: macro-in-comment %doc -> should be %%doc
removed

> - %doc: There is also a README

added.

> Not much to do, but not approving this now, because this is a merge review and
> not a normal package review...    

out of interest: the package has been around for ages, what would the formal approval really do?

Comment 3 Thomas Spura 2010-07-19 09:51:50 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Needswork:
> > - https://fedoraproject.org/wiki/Packaging/Guidelines#Parallel_make
> done
> > - please use INSTALL="install -p", when installing
> done
> 
> > - libXxf86dga.x86_64: W: name-repeated-in-summary C libXxf86dga
> >   A slightly bigger description wouldn't hurt.
> 
> no, people may be tempted to use it then ;)

Heh, that's to risky.^^
 
> > - libXxf86dga.src:51: W: macro-in-comment %doc -> should be %%doc
> removed
> 
> > - %doc: There is also a README
> 
> added.

Thanks.
 
> > Not much to do, but not approving this now, because this is a merge review and
> > not a normal package review...    
> 
> out of interest: the package has been around for ages, what would the formal
> approval really do?    

The packages needing merge reviews used to be in Fedora Core and did not get any review yet. This makes sure, that they don't violate the guidelines (e.g. have a correct license and so on).
In this case it was more a cosmetic issue, but e.g. the python guidelines changed quite a lot, so python packages in the merge review queue will need more changes.
(That's the reason, why I started with xorg-x11-* ones ;-))

Also see (Don't know, why that's a draft...):
https://fedoraproject.org/wiki/Merge_Reviews
http://lists.fedoraproject.org/pipermail/devel/2010-July/138566.html