Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 226042

Summary: Merge Review: libselinux
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Adel Gadllah <adel.gadllah>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: adel.gadllah, dwalsh, redhat-bugzilla
Target Milestone: ---Flags: adel.gadllah: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-21 22:20:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 426387    
Attachments:
Description Flags
Patch to adress remaining spec file issues none

Description Nobody's working on this, feel free to take it 2007-01-31 19:27:17 UTC
Fedora Merge Review: libselinux

http://cvs.fedora.redhat.com/viewcvs/devel/libselinux/
Initial Owner: dwalsh@redhat.com

Comment 1 Adel Gadllah 2008-01-01 21:30:35 UTC
OK taking this one:

First the rpmlint warnings/errors:

-----------------
> libselinux.x86_64: W: invalid-license Public domain
> libselinux.x86_64: W: invalid-license uncopyrighted
-----------------
The license tag is indeed invalid it should be 
"Public Domain" 
See: http://fedoraproject.org/wiki/Licensing
-----------------
> libselinux.x86_64: W: no-url-tag
-----------------
Why? Please add an URL tag pointing to the upstream homepage
-----------------
> libselinux-python.x86_64: E: script-without-shebang >
/usr/lib64/python2.5/site-packages/selinux.py
-----------------
As this file is not intended to be executed directly chmod -x it (mode 0644 not
0755) (If it is then please add a shebang)
-----------------
libselinux-python.x86_64: W: summary-not-capitalized python bindings for libselinux
-----------------
OK thats an easy one ;)
-----------------
libselinux-python.x86_64: E: description-line-too-long The libselinux-python
package contains the python bindings for developing SELinux
-----------------
Please split this into 80 char lines.
-----------------

Now general comments to the spec file:

>%files devel
>%defattr(-,root,root)
>%{_libdir}/libselinux.a

Please remove this file or if you want to ship it for some reason place it in a
-static subpackage.


------

>%files python
>%defattr(-,root,root,0755)
>%{_libdir}/python*/site-packages/_selinux.so
>%{_libdir}/python*/site-packages/selinux.py*

Instead of {_libdir}/python*/site-packages do this:
Add 
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from
distutils.sysconfig import get_python_lib; print get_python_lib()")}
to the top of the spec file and use %{python_sitelib} instead.
------

>%build
>make clean
>make CFLAGS="-g %{optflags}" swigify
>make CFLAGS="-g %{optflags}" all pywrap

Please append %{?_smp_mflags} to the make calls (if it does not break the build).

====
If you want I can attach a patch with the changes mentioned above to help
speeding up the review process.


Comment 2 Daniel Walsh 2008-01-03 20:39:55 UTC
Fixes are in libselinux-2.0.46-3

Thanks.

Comment 3 Adel Gadllah 2008-01-04 00:32:28 UTC
(In reply to comment #2)
> Fixes are in libselinux-2.0.46-3
> 
> Thanks.

OK, the rpmlint output is now:
"libselinux-python.x86_64: W: no-documentation"
which is fine!

The only remaining issue is the python site-packages path.
Once fixed I will approve the package.

Comment 4 Adel Gadllah 2008-01-04 17:24:52 UTC
one more thing:
>%defattr(-,root,root,0755)
should be replaced with
>%defattr(-,root,root,0755) 
(set the correct modes during %install)

Comment 5 Daniel Walsh 2008-01-04 19:19:26 UTC
adel you are replacing one command with the same.

Comment 6 Adel Gadllah 2008-01-15 16:54:38 UTC
(In reply to comment #5)
> adel you are replacing one command with the same.

... stupid copy and paste sorry; 
I meant "%defattr(-,root,root,-)"

Comment 7 Adel Gadllah 2008-01-16 20:19:25 UTC
Created attachment 291883 [details]
Patch to adress remaining spec file issues

Daniel, this patch should fixes the issues I mentioned in this bug. I moved
libselinux.a into a -static package because it seems to be needed.

Comment 8 Daniel Walsh 2008-01-21 20:59:42 UTC
fixed in libselinux-2.0.47-4.fc9

Comment 9 Adel Gadllah 2008-01-21 21:48:26 UTC
(In reply to comment #8)
> fixed in libselinux-2.0.47-4.fc9

Looks fine now.

=> APPROVED!