Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 226022

Summary: Merge Review: libgpod
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Todd Zullinger <tmz>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bnocera, kevin, tmz
Target Milestone: ---Flags: tmz: fedora-review+
kevin: fedora-cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-30 14:39:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nobody's working on this, feel free to take it 2007-01-31 19:24:10 UTC
Fedora Merge Review: libgpod

http://cvs.fedora.redhat.com/viewcvs/devel/libgpod/
Initial Owner: alexl@redhat.com

Comment 1 Todd Zullinger 2007-02-02 17:49:03 UTC
I'll review this.

Comment 2 Todd Zullinger 2007-02-02 19:50:12 UTC
MUST items verified

* rpmlint runs without errors on the srpm (just a minor warning, output below)
* Adheres to naming guidelines
* Specfile name matches package name
* Meets packaging guidelines (except for %makeinstall usage, see below)
* License meets open-source requirements
* License included in %doc
* License field matches the upstream license
* Specfile is in American English
* Specfile is legible
* Source matches upstream (sha1: b2aece62a206a5b703c50e6625b173217f1d67a6)
* Builds, installs, and works (tested on FC6, i386)
* Owns directories that it creates
* Does not own files or directories of other packages
* File list has no duplicates
* File perms are sane
* Specfile includes %clean section
* Macros used consistently
* Package contains code or permissible content
* Headers are in -devel subpackage
* Devel package properly requires pkgconfig and the base libgpod package
* Libtool archives and static archives are excluded


SHOULD items verified

* Builds in mock against fedora-{5,6,development}-i386-core targets
* Scriplets are sane
* Package functions correctly (tested on FC6)


$ rpmlint libgpod-0.4.2-1.fc7.src.rpm 
W: libgpod setup-not-quiet

This warning is very minor and easily silenced with the addition of -q to
%setup. It's not a blocker as far as I know.

Another very a minor point, the preferred value for the BuildRoot tag is
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
This is not a blocker.

The one thing that should be fixed is to change %makeinstall to
%{__make} DESTDIR=%{buildroot} install as per the packaging guidelines.


APPROVED

Comment 3 Todd Zullinger 2007-02-02 19:53:54 UTC
It should probably also be noted here for future reference that this package
does not contain the python module that is shipped with libgpod.  This is only
due to the requirement of that module on the python-eyed3 package which is only
available in Extras.  Once the merge is completed and libgpod can safely require
python-eyed3, then the python-gpod package from extras should be rolled into
this package.

I'd also like to volunteer to co-maintain this package.  I have upstream commit
privileges* and follow the development closely.  I'm also the maintainer of the
python-gpod package currently in Extras.

* not because I'm much of a coder, but because I've helped with automake and
documentation issues

Comment 4 Matthias Clasen 2007-02-04 03:09:14 UTC
Its probably best to file a separate bug for the python bindings, and put it on
FC7Tracker.

Comment 5 Todd Zullinger 2007-02-04 06:16:47 UTC
Thanks Matthias, I'll look to do that after the review process.  I simply wanted
to make a note of why the functionality was disabled in this review so that
anyone wondering will know it was intentional and necessary.

I'm reassigning this to myself as the reviewer of the package, as per my
understanding of how the merge reviews are to be handled.  As I understand it,
the bug should be assigned to the reviewer for the review and then reassigned to
the maintainer afterward.  If you feel I am in error for doing so, please let me
know why.

Comment 6 Bastien Nocera 2007-05-30 14:39:50 UTC
Approved, so closing now. Todd has commit rights.

Comment 7 Todd Zullinger 2007-08-03 15:13:27 UTC
Package Change Request
======================
Package Name: libgpod
Updated Fedora Owners: bnocera@redhat.com,tmz@pobox.com

(This might need an explicit ACK from Bastien, so the CVS admins don't think I'm
trying to pull one over. :)

Comment 8 Kevin Fenzi 2007-08-03 16:54:52 UTC
Yes, Bastien: Can you ack this change here?

Comment 9 Bastien Nocera 2007-08-03 22:35:04 UTC
Yep, Todd's the one doing the work :)

Comment 10 Kevin Fenzi 2007-08-04 06:08:23 UTC
thanks. cvs done.