Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 225981

Summary: Merge Review: lcms
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Alexander Larsson <alexl>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: alexl, bugs.michael, dan, kwizart
Target Milestone: ---Flags: dan: fedora-review+
wtogami: fedora-cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-10 20:44:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
patch to fix the discussed issues none

Description Nobody's working on this, feel free to take it 2007-01-31 19:17:52 UTC
Fedora Merge Review: lcms

http://cvs.fedora.redhat.com/viewcvs/devel/lcms/
Initial Owner: alexl@redhat.com

Comment 1 Dan Horák 2007-02-04 12:27:27 UTC
should be quick as it is coming from Extras originally :-)

Comment 2 Dan Horák 2007-02-04 13:19:08 UTC
OK	source files match upstream:
	    930ef7de15eb028c1cdbfe3f1170aaa1d5b0b4d45a8fa496d944216e155122c2 
lcms-1.15.tar.gz
OK	package meets naming and versioning guidelines.
OK	specfile is properly named, is cleanly written and uses macros consistently.
OK	dist tag is present.
OK	build root is correct.
OK	license is open source-compatible. License text included in package.
OK	latest version is being packaged.
OK	BuildRequires are proper.
OK	compiler flags are appropriate.
OK	%clean is present.
OK	package builds in mock (i386).
OK	package installs properly
OK	debuginfo package looks complete.
OK	final provides and requires are sane:
OK	shared libraries are added to the regular linker search paths, ldconfig is run.
OK	owns the directories it creates.
OK	doesn't own any directories it shouldn't.
OK	no duplicates in %files.
OK	file permissions are appropriate.
OK	scriptlets are present and they are sane.
OK	code, not content.
OK	documentation is small, so no -docs subpackage is necessary.
OK	%docs are not necessary for the proper functioning of the package.
OK	headers in devel subpackage.
OK	pkgconfig filesin devel subpackage.
OK	no libtool .la are packaged.
OK	not a GUI app.

MUST FIX:

BAD	license field does NOT match the actual license.

	The License tag contains LGPL, but the license in the COPYING file and in the
source files headers is different. The Web say it is MIT license.

SHOULD FIX:

BAD	 rpmlint is NOT silent.

I: lcms checking
E: lcms zero-length /usr/share/doc/lcms-1.15/ChangeLog
	the ChangeLog could be omited

I: python-lcms checking
W: python-lcms summary-ended-with-dot Python interface to LittleCMS.

Also a newer version 1.16 was already released.


Comment 3 Dan Horák 2007-02-04 13:23:25 UTC
Created attachment 147300 [details]
patch to fix the discussed issues

Comment 4 Michael Schwendt 2007-02-04 15:34:04 UTC
> Requires:       python, %{python_sitearch}

The automatic "python(abi) = ..." dep should suffice. Path deps make
Yum download the extra filelists, which is unnecessary in this case.

> touch ${RPM_BUILD_ROOT}%{python_sitearch}/lcms.py{c,o}

> %ghost %{python_sitearch}/lcms.py?

We no longer %ghost compiled Python files.

> %{_libdir}/*.a

Static libs can go, right?


Comment 5 Alexander Larsson 2007-02-05 13:06:41 UTC
All comments fixed in 1.16-1.

Also, this was once an extras package that moved to core due to f-spot requiring
it. I'll gladly give it back to whoever else wants to maintain it. Michael,
you're latest in the changelog. Are you interested?

Comment 6 Michael Schwendt 2007-02-05 14:16:47 UTC
No particular interest. I've never been a maintainer of lcms, just
a bug-fix grunt.


Comment 7 Dan Horák 2007-02-07 09:24:33 UTC
Did not you forget to fix the Requires in the python subpackage from comment #4?
I agree with Michael on this.

It looks like the new sources have a new feature - almost all files have the
exec bit set. Please, unset it at least from *.c and *.h files that are packaged
into the -debug subpackage.

find . -name \*.[ch] | xargs chmod -x

Comment 8 Alexander Larsson 2007-02-08 11:17:47 UTC
Fixed in 1.16-3.

Comment 9 Dan Horák 2007-02-09 08:28:36 UTC
I don't see any other problems, so this package is APPROVED.

Comment 10 Alexander Larsson 2007-05-15 07:47:50 UTC
Package Change Request
======================
Package Name: lcms
Updated Fedora Owners: andreas.bierfert@lowlatency.de, kwizart@gmail.com

Handing over lcms maintainership.

Comment 11 Nicolas Chauvet (kwizart) 2007-05-15 16:51:27 UTC
Thx for doing this!

For now i haven't seen a FC-6 branch when doing cvs co lcms
I would like to update FC-6 from current devel (with no changes since this will
lead to broken upgrade path...)

Do adread agree with this ? 
(I explain that it is safe here : https://bugzilla.redhat.com/236067 )
lcsm 0.16 is also marked stable on their website...

Should we ask for package maintainers to confirm and/or test a 0.16 package for
lcms ? I don't think that is necessary...

1.17 is unstable for now and i will work on it after F7 is out... (for F8 rawhide)





Comment 12 Matthias Clasen 2007-08-10 20:44:34 UTC
This review is done.