Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 225980

Summary: Merge Review: latex2html
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Karel Klíč <kklic>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: ed, jnovy, kklic, mtasaka, rvokal
Target Milestone: ---Flags: kklic: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-03 10:12:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nobody's working on this, feel free to take it 2007-01-31 19:17:49 UTC
Fedora Merge Review: latex2html

http://cvs.fedora.redhat.com/viewcvs/devel/latex2html/
Initial Owner: jnovy@redhat.com

Comment 1 Ed Hill 2007-02-09 03:38:08 UTC
good:
 + source matches upstream

needswork:
 - The license looks problematic (it has a "no fees or compensation" 
   clause) and the package does not include a copy of it despite 
   the explicit terms saying it must be "prominently carried on all 
   copies".

I'll continue with the review but the license bits probably (?) need 
attention first.

Comment 2 Karel Klíč 2009-12-10 11:18:09 UTC
[YES] source files match upstream: 275ab6cfa8ca9328446b7f40d8dc302e  latex2html-2008.tar.gz
[YES] source files match upstream: 7951e334e313a1a88946a1171c72e78f  l2h-2K8-jp20081220.tar.gz
[YES] package meets naming and versioning guidelines 
[YES] specfile is properly named, uses macros consistently
[???] specfile is cleanly written. 
      The spec file contains a lot of perl one-liners. 
      Wouldn't it be better to write a patch that fixes the scripts generating wrong paths
      instead of those regular expressions? 
      Is it too difficult?
[YES] dist tag is present
[YES] build root is correct
[YES] license field matches the actual license
[YES] license is open source-compatible
[FAIL] license text included in package: license not included in the package
       It is included in the source archive.
       It should be installed in "/usr/share/doc/latex2html-2008/"
[YES] latest version is being packaged
[YES] BuildRequires are proper
[YES] package builds in mock
[NO] rpmlint is silent

$rpmlint ./latex2html-2008-3.fc13.src.rpm 
latex2html.src:125: W: rpm-buildroot-usage %build perl -pi -e"s,${RPM_BUILD_ROOT},," l2hconf.pm
latex2html.src: W: mixed-use-of-spaces-and-tabs (spaces: line 79, tab: line 92)
1 packages and 0 specfiles checked; 0 errors, 2 warnings.

$ rpmlint ./latex2html-2008-3.fc13.noarch.rpm 
latex2html.noarch: E: non-executable-script /usr/share/latex2html/cweb2html/cweb2html 0644 /usr/bin/perl
latex2html.noarch: W: hidden-file-or-dir /usr/share/latex2html/docs/.latex2html-init
latex2html.noarch: E: non-executable-script /usr/share/jlatex2html/makeseg/makeseg 0644 /usr/bin/perl
latex2html.noarch: E: non-executable-script /usr/share/latex2html/makemap 0644 /usr/bin/perl
latex2html.noarch: E: non-executable-script /usr/share/jlatex2html/makemap 0644 /usr/bin/perl
latex2html.noarch: E: wrong-script-interpreter /usr/share/jlatex2html/cweb2html/makemake.pl /usr/local/bin/perl
latex2html.noarch: E: non-executable-script /usr/share/jlatex2html/cweb2html/makemake.pl 0644 /usr/local/bin/perl
latex2html.noarch: E: non-executable-script /usr/share/jlatex2html/cweb2html/cweb2html 0644 /usr/bin/perl
latex2html.noarch: E: non-executable-script /usr/share/latex2html/makeseg/makeseg 0644 /usr/bin/perl
latex2html.noarch: W: hidden-file-or-dir /usr/share/jlatex2html/docs/.latex2html-init
latex2html.noarch: E: wrong-script-interpreter /usr/share/latex2html/cweb2html/makemake.pl /usr/local/bin/perl
latex2html.noarch: E: non-executable-script /usr/share/latex2html/cweb2html/makemake.pl 0644 /usr/local/bin/perl
1 packages and 0 specfiles checked; 10 errors, 2 warnings.

[YES] final provides and requires look sane
[OK] %check is not present
[YES] no shared libraries are added to the regular linker search paths in app package
[YES] owns the directories it creates
[YES] doesn't own any directories it shouldn't
[YES] no duplicates in %files
[YES] file permissions are appropriate
[YES] scriptlets ok
[YES] code, not content
[YES] documentation is small, so no -docs subpackage is necessary
[???] %docs are not necessary for the proper functioning of the package
      Documentation is not marked as %doc, and it is included 
      in both /usr/share/latex2html/doc and in /usr/share/jlatex2html
      It is not compiled (just the .tex source, no .dvi/pdf/ps)

      It should be compiled, marked by %doc in %files, and it should not be 
      included in /usr/share/latex2html.

      The file readme.hthtml should be in %doc

      /usr/share/makeseg/makeseg.tex should be built and the .dvi/pdf/ps 
      should be included as %doc, but the .tex file should not be included.
      
[YES] no headers
[YES] no pkgconfig files
[YES] no libtool .la droppings
[YES] not a GUI app

Comment 3 Jindrich Novy 2009-12-11 14:47:03 UTC
(In reply to comment #2)
> [???] specfile is cleanly written. 
>       The spec file contains a lot of perl one-liners. 
>       Wouldn't it be better to write a patch that fixes the scripts generating
> wrong paths
>       instead of those regular expressions? 
>       Is it too difficult?

Yes, it is not trivial and it works so no need to break it.

> [FAIL] license text included in package: license not included in the package
>        It is included in the source archive.
>        It should be installed in "/usr/share/doc/latex2html-2008/"

Added.

> [NO] rpmlint is silent
> 
> $rpmlint ./latex2html-2008-3.fc13.src.rpm 
> latex2html.src:125: W: rpm-buildroot-usage %build perl -pi
> -e"s,${RPM_BUILD_ROOT},," l2hconf.pm
> latex2html.src: W: mixed-use-of-spaces-and-tabs (spaces: line 79, tab: line 92)
> 1 packages and 0 specfiles checked; 0 errors, 2 warnings.
> 
> $ rpmlint ./latex2html-2008-3.fc13.noarch.rpm 
> latex2html.noarch: E: non-executable-script
> /usr/share/latex2html/cweb2html/cweb2html 0644 /usr/bin/perl
> latex2html.noarch: W: hidden-file-or-dir
> /usr/share/latex2html/docs/.latex2html-init
> latex2html.noarch: E: non-executable-script
> /usr/share/jlatex2html/makeseg/makeseg 0644 /usr/bin/perl
> latex2html.noarch: E: non-executable-script /usr/share/latex2html/makemap 0644
> /usr/bin/perl
> latex2html.noarch: E: non-executable-script /usr/share/jlatex2html/makemap 0644
> /usr/bin/perl
> latex2html.noarch: E: wrong-script-interpreter
> /usr/share/jlatex2html/cweb2html/makemake.pl /usr/local/bin/perl
> latex2html.noarch: E: non-executable-script
> /usr/share/jlatex2html/cweb2html/makemake.pl 0644 /usr/local/bin/perl
> latex2html.noarch: E: non-executable-script
> /usr/share/jlatex2html/cweb2html/cweb2html 0644 /usr/bin/perl
> latex2html.noarch: E: non-executable-script
> /usr/share/latex2html/makeseg/makeseg 0644 /usr/bin/perl
> latex2html.noarch: W: hidden-file-or-dir
> /usr/share/jlatex2html/docs/.latex2html-init
> latex2html.noarch: E: wrong-script-interpreter
> /usr/share/latex2html/cweb2html/makemake.pl /usr/local/bin/perl
> latex2html.noarch: E: non-executable-script
> /usr/share/latex2html/cweb2html/makemake.pl 0644 /usr/local/bin/perl
> 1 packages and 0 specfiles checked; 10 errors, 2 warnings.
> 

Fixed.

> [???] %docs are not necessary for the proper functioning of the package
>       Documentation is not marked as %doc, and it is included 
>       in both /usr/share/latex2html/doc and in /usr/share/jlatex2html

"docs" and "example" directory is now marked as %doc

>       It is not compiled (just the .tex source, no .dvi/pdf/ps)
> 
>       It should be compiled, marked by %doc in %files, and it should not be 
>       included in /usr/share/latex2html.
> 
>       The file readme.hthtml should be in %doc

readme.hthtml is mistakenly twice in the tarball. The copy in the root is bogus, thus deleted.

> 
>       /usr/share/makeseg/makeseg.tex should be built and the .dvi/pdf/ps 
>       should be included as %doc, but the .tex file should not be included.
> 

Leaving makeseg as is because it ships the makeseg script as well.

Comment 4 Karel Klíč 2009-12-11 15:58:18 UTC
Shouldn't documentation in LaTeX format (.tex) be compiled to something more readable, e.g. PDF?

There is no answer in packaging guideline.

I am giving review+, because the package is good enough shape now.

Comment 5 Jindrich Novy 2009-12-11 16:38:15 UTC
The TeX documentation is not essential wrt functionality of latex2html. The reason to ship the tex variant is that one can convert the tex file directly with latex2html if he wants to read it ;) This could be used to test latex2html. Furthermore pdf documentation is a bit wasteful as it is too big.

Thanks for the review :)