Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 225963

Summary: Merge Review: kdelibs
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Rex Dieter <rdieter>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: chitlesh, rdieter, than
Target Milestone: ---Flags: rdieter: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-06 12:43:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nobody's working on this, feel free to take it 2007-01-31 19:15:07 UTC
Fedora Merge Review: kdelibs

http://cvs.fedora.redhat.com/viewcvs/devel/kdelibs/
Initial Owner: than@redhat.com

Comment 1 Rex Dieter 2007-02-03 20:21:36 UTC

*** This bug has been marked as a duplicate of 227222 ***

Comment 2 Rex Dieter 2007-02-07 13:33:23 UTC
On retrospect, makes much more sense to review Core package as-is, and discuss
mods and co-maintainership after.

Comment 3 Rex Dieter 2007-02-07 13:34:23 UTC
*** Bug 227222 has been marked as a duplicate of this bug. ***

Comment 4 Rex Dieter 2007-02-07 17:53:11 UTC
On first glance (otherwise, looking good):

* SHOULD omit
Requires: cups ...
Obsoletes: %{name}2
Obsoletes: kdesupport
Obsoletes: kdoc
that's all ancient history, no need, imo, to carry the baggage anymore.

* -devel pkg SHOULD
Requires: qt-devel
unversioned here is ok, main pkg already includes Requires: qt >= EVR
omit legacy crud:
Obsoletes: kdesupport-devel

* SHOULD omit
Requires(pre,post): desktop-file-utils
per http://fedoraproject.org/wiki/Packaging/ScriptletSnippets
it is no longer required (FC-5+)


Comment 5 Rex Dieter 2007-02-12 17:01:39 UTC
Since kdelibs review includes no MUST blockers, I'll mark this APPROVED.

We can address the SHOULD items post-merge.

Comment 6 Ngo Than 2007-02-27 17:03:38 UTC
it's now fixed in kdelibs-3_5_6-2_fc7. New package has been built in rawhide.