Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 225955

Summary: Merge Review: jwhois
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: mitr, vcrhonek
Target Milestone: ---Flags: lkundrak: fedora-review+
gwync: fedora-cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-12-07 08:23:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nobody's working on this, feel free to take it 2007-01-31 19:14:12 UTC
Fedora Merge Review: jwhois

http://cvs.fedora.redhat.com/viewcvs/devel/jwhois/
Initial Owner: mitr@redhat.com

Comment 1 Lubomir Kundrak 2007-11-20 16:16:31 UTC
You don't use _smp_mflags at all
You don't need to [ "$RPM_BUILD_ROOT" != "/" ] before rm -fr $RPM_BUILD_ROOT

RPMlint:

jwhois.src:11: W: unversioned-explicit-obsoletes fwhois
jwhois.src:11: W: unversioned-explicit-obsoletes whois

Just fine if jwhois is incompatible. Is it?

jwhois.src:65: W: macro-in-%changelog lang

use double %.

Comment 2 Lubomir Kundrak 2007-11-27 12:32:22 UTC
Ping on this.

Comment 3 Vitezslav Crhonek 2007-11-27 13:28:55 UTC
(In reply to comment #1)
> You don't use _smp_mflags at all

I found no bug against _smp_flags in history and it works, so I will add it.

> You don't need to [ "$RPM_BUILD_ROOT" != "/" ] before rm -fr $RPM_BUILD_ROOT

I will remove it.

> RPMlint:
> 
> jwhois.src:11: W: unversioned-explicit-obsoletes fwhois
> jwhois.src:11: W: unversioned-explicit-obsoletes whois
> 
> Just fine if jwhois is incompatible. Is it?

I think so, but I'm not sure. AFAIK fwhois and whois are not used in Fedora,
fwhois is dead...? Mirek, do you know more about it?

> jwhois.src:65: W: macro-in-%changelog lang
> 
> use double %.

I will fix it.


Comment 4 Miloslav Trma─Ź 2007-11-27 13:35:38 UTC
IIRC both jwhois and fwhois were obsoleted by jwhois at least since RHL 6.  I
don't think removing the Obsoletes: would be a problem.

Comment 5 Lubomir Kundrak 2007-11-28 15:15:15 UTC
Please replace

Buildroot: %{_tmppath}/%{name}-%{version}-root

with

BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

Comment 6 Lubomir Kundrak 2007-12-04 14:46:24 UTC
Ping on this.

Comment 7 Lubomir Kundrak 2007-12-06 13:52:31 UTC
I see you fixed the buildroot in CVS. Now package looks almost perfect. -- I
noticed one more thing: I believe that autoconf and automake dependencies are
unnecessary, you don't rebuild autotools files.

Comment 8 Vitezslav Crhonek 2007-12-06 14:57:05 UTC
You're right, fixed in CVS.

Comment 9 Lubomir Kundrak 2007-12-07 08:19:46 UTC
The package seems fine now. Thanks.

Comment 10 Vitezslav Crhonek 2014-09-24 10:30:08 UTC
Package Change Request
======================
Package Name: jwhois
New Branches: epel7
Owners: vcrhonek@redhat.com

The package is not available in RHEL7.
https://bugzilla.redhat.com/show_bug.cgi?id=1145288

Comment 11 Gwyn Ciesla 2014-09-24 11:17:15 UTC
Git done (by process-git-requests).

In the future use your FAS account name, not your email address.